summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Anderson2019-02-28 16:19:01 +0000
committerAndrew Anderson2019-02-28 16:19:01 +0000
commit6136d4b3b7e2025d8e9fb7c729538f67547adaec (patch)
tree7060b37e4d4a2a51a0693f2da78877e1e3c57d59 /PKGBUILD
parentb3777e9b8f0ca1eb4bfbcb6c688f002eae1e69f6 (diff)
downloadaur-6136d4b3b7e2025d8e9fb7c729538f67547adaec.tar.gz
Fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a347956907a0..eba856ed694f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,13 +8,13 @@ _PkgName=OpenBLAS
_pkgname=openblas
pkgver=0.3.4
_lapackver=3.8.0
-pkgrel=14
+pkgrel=15
pkgdesc="Optimized BLAS library based on GotoBLAS2 1.13 BSD (providing blas, lapack, and cblas)"
arch=('any')
url="http://www.openblas.net/"
license=('BSD')
depends=('gcc-libs')
-makedepends=('perl')
+makedepends=('perl' 'aarch64-linux-gnu-gcc')
provides=('aarch64-linux-gnu-openblas' "aarch64-linux-gnu-blas=${_lapackver}" "aarch64-linux-gnu-lapack=${_lapackver}" "aarch64-linux-gnu-cblas=${_lapackver}" "aarch64-linux-gnu-lapacke=${_lapackver}")
conflicts=()
options=(!emptydirs !strip)
@@ -25,6 +25,7 @@ _ncpus=$(eval "cat /proc/cpuinfo | grep MHz | wc -l")
_config="BINARY=64 CC=aarch64-linux-gnu-gcc FC=aarch64-linux-gnu-gfortran HOSTCC=gcc TARGET=ARMV8 \
USE_OPENMP=1 USE_THREAD=1 USE_COMPILER_TLS=0 \
+ NO_STATIC=0 NO_SHARED=0 \
NO_LAPACK=0 BUILD_LAPACK_DEPRECATED=1 \
MAKE_NB_JOBS=${_ncpus} \
PREFIX=/usr/aarch64-linux-gnu "