summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGaël PORTAY2023-10-03 02:25:47 +0200
committerGaël PORTAY2023-10-03 02:25:47 +0200
commit378cebea67dd88ab1ee3b81dd703bafc510040d9 (patch)
tree8642bffc47cff1ca3b5f6e5068f23c6582fc8000 /PKGBUILD
parente9881affd0c8272865f309999c97ae6052e0ba19 (diff)
downloadaur-378cebea67dd88ab1ee3b81dd703bafc510040d9.tar.gz
v2023.08-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 8 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 998907a054a7..3a1da4322be7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,11 @@ pkgdesc="Ready-to-use cross-compilation toolchain provided by bootlin.com"
arch=("x86_64")
url="https://toolchains.bootlin.com/"
license=("GPL")
-source=("https://toolchains.bootlin.com/downloads/releases/toolchains/aarch64be/tarballs/aarch64be--musl--bleeding-edge-2023.08-1.tar.bz2")
-sha256sums=('b2b30d563559664d0efc23eb00bc469c808bdfd400198967ba1255863301efc0')
+source=("https://toolchains.bootlin.com/downloads/releases/toolchains/aarch64be/tarballs/aarch64be--musl--bleeding-edge-2023.08-1.tar.bz2"
+ "profile.sh-aarch64be-musl-bleeding-edge-toolchain")
+install="hooks.install-aarch64be-musl-bleeding-edge-toolchain"
+sha256sums=('b2b30d563559664d0efc23eb00bc469c808bdfd400198967ba1255863301efc0'
+ '942b6ff12b13c64748ce3d2b00829cc8649260b259c1efa06e4d6c6862a6661e')
build() {
cd "aarch64be--musl--bleeding-edge-2023.08-1"
@@ -24,4 +27,7 @@ package() {
mkdir -p "$pkgdir/opt/aarch64be-musl-bleeding-edge/"
cp -a * "$pkgdir/opt/aarch64be-musl-bleeding-edge/"
rm -f "$pkgdir/opt/aarch64be-musl-bleeding-edge/{buildroot.config,relocate-sdk.sh,summary.csv,share/buildroot/sdk-location}"
+
+ mkdir -p "$pkgdir/etc/profile.d/"
+ install -m0644 "$srcdir/profile.sh-aarch64be-musl-bleeding-edge-toolchain" "$pkgdir/etc/profile.d/aarch64be-musl-bleeding-edge-toolchain.sh"
}