summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndré Ericson2015-07-07 00:08:59 -0300
committerAndré Ericson2015-07-07 00:08:59 -0300
commit2e21959b2248d3e8ded79995fca836449b7d2790 (patch)
treeb27dc3b7d5b6339a5d7fcc4bea2325630ce6ab42 /PKGBUILD
downloadaur-2e21959b2248d3e8ded79995fca836449b7d2790.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c36761532c4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Rorschach <r0rschach@lavabit.com>
+# Contributor: Andrew Kravchuk <awkravchuk@gmail.com>
+# Contributor: aericson <de.ericson@gmail.com>
+
+pkgname=aarchup
+pkgver=1.7.3
+pkgrel=2
+pkgdesc="Fork of archup a small and lightweight update-notifier for archlinux."
+url="https://github.com/aericson/aarchup"
+arch=('i686' 'x86_64')
+license="GPL"
+depends=('pacman' 'libnotify' 'gtk2')
+makedepends=('libnotify' 'autoconf' 'gzip')
+source=("https://github.com/aericson/aarchup/archive/$pkgver.zip")
+md5sums=('204df2d8b83ce76c79b88ba4b10f370e')
+backup=('etc/systemd/system/aarchup.timer')
+optdepends=('cower: AUR support(--aur)')
+install='aarchup.install'
+
+prepare() {
+ mv -v $pkgname-$pkgver/src/* $pkgname-$pkgver/
+ rmdir $pkgname-$pkgver/src
+}
+
+build() {
+ cd $pkgname-$pkgver/
+ autoconf || return 1
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd $pkgname-$pkgver/
+ make DESTDIR="$pkgdir/" install || return 1
+}