summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Butler2022-02-05 01:40:46 +0000
committerAlex Butler2022-02-05 01:40:46 +0000
commit913e578bb9d6c7cbbfd7e5f4b4faa8b0d28f1037 (patch)
tree7ad075a69097af9bc7a764eed389f6f479e4ae22 /PKGBUILD
parente16cff65ae2db9e08b3afc5aeb8c0e360ccfe1b2 (diff)
downloadaur-913e578bb9d6c7cbbfd7e5f4b4faa8b0d28f1037.tar.gz
0.1.1-2
Fix completions install paths
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e0210817c346..1559b7490acf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Alex Butler <alexheretic@gmail.com>
pkgname=ab-av1
pkgver=0.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="AV1 encoding tool with fast VMAF sampling."
arch=('x86_64')
url="https://github.com/alexheretic/ab-av1"
@@ -26,12 +26,12 @@ package() {
bin="$pkgname-$pkgver"/target/release/ab-av1
# generate completions
- mkdir -p "$pkgdir/usr/share/bash-completion/completions"
- "$bin" print-completions bash > "$pkgdir/usr/share/bash-completion/completions/ab-av1"
- mkdir -p "$pkgdir/usr/share/share/fish/completions"
- "$bin" print-completions fish > "$pkgdir/usr/share/share/fish/completions/ab-av1.fish"
- mkdir -p "$pkgdir/usr/share/zsh/site-functions"
- "$bin" print-completions zsh > "$pkgdir/usr/share/zsh/site-functions/_ab-av1"
+ "$bin" print-completions "bash" > out.txt
+ install -Dm644 out.txt "$pkgdir/usr/share/bash-completion/completions/ab-av1"
+ "$bin" print-completions "fish" > out.txt
+ install -Dm644 out.txt "$pkgdir/usr/share/fish/completions/ab-av1.fish"
+ "$bin" print-completions "zsh" > out.txt
+ install -Dm644 out.txt "$pkgdir/usr/share/zsh/site-functions/_ab-av1"
- install -Dm 755 "$bin" -t "$pkgdir/usr/bin"
+ install -Dm755 "$bin" -t "$pkgdir/usr/bin"
}