summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlex Butler2022-02-03 22:13:49 +0000
committerAlex Butler2022-02-03 22:13:49 +0000
commita8459b06ee87221bfd11b068f7b3ac491b294c97 (patch)
treed0ee056ecedd04d83ba6fb240f4736ecb5f140c3 /PKGBUILD
downloadaur-a8459b06ee87221bfd11b068f7b3ac491b294c97.tar.gz
0.1.0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a0567be40d61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Alex Butler <alexheretic@gmail.com>
+pkgname=ab-av1
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="AV1 encoding tool with fast VMAF sampling."
+arch=('x86_64')
+url="https://github.com/alexheretic/ab-av1"
+license=('Apache-2.0')
+depends=('svt-av1'
+ 'ffmpeg'
+ 'vmaf'
+ 'opus')
+optdepends=()
+makedepends=('rust'
+ 'git')
+source=("https://github.com/alexheretic/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('584657e24b3bf13a71fbea33d06d08e05322c0281a6a145947759df9c5bbbcba')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo +stable build --release --locked --target-dir=target
+}
+
+package() {
+ install -Dm 755 "$pkgname-$pkgver"/target/release/ab-av1 -t "$pkgdir/usr/bin"
+}