summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCarlos Franke2016-09-24 13:36:12 +0200
committerCarlos Franke2016-09-24 13:36:12 +0200
commitb13ad305d710f370f677ebd36f4ef512a1083276 (patch)
tree0ae5bbd57dae5ae729d0d29b8ad0681197478ccb /PKGBUILD
downloadaur-abbrase-git.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..73742e19526d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Carlos Franke <carlos_franke at lemtank dot de>
+_pkgname=abbrase
+pkgname=$_pkgname-git
+pkgver=r41.3834b28
+pkgrel=1
+pkgdesc=""
+arch=('x86_64')
+url="https://github.com/rmmh/abbrase"
+license=('custom')
+depends=()
+makedepends=('git')
+provides=($_pkgname)
+conflicts=($_pkgname)
+source=("$pkgname::git+https://github.com/rmmh/abbrase.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+
+# Git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" PREFIX="/usr" install
+}