summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMikael Blomstrand2018-10-17 16:54:38 +0200
committerMikael Blomstrand2018-10-17 16:54:38 +0200
commit4bd7852b86383199d4c2afa68f455d0d6c9af59c (patch)
tree320360e07d6be18631752c845398f974a5a4332b /PKGBUILD
downloadaur-4bd7852b86383199d4c2afa68f455d0d6c9af59c.tar.gz
init
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b5796b357348
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Mikael Blomstrand <mbloms@kth.se>
+
+pkgname=abi-dumper
+pkgver=1.1
+pkgrel=1
+pkgdesc="Dump ABI of an ELF object containing DWARF debug info."
+arch=('i686' 'x86_64')
+url="https://github.com/lvc/abi-dumper"
+license=('LGPL')
+# Dependencies as listed in INSTALL.
+depends=(perl elfutils binutils vtable-dumper ctags)
+conflicts=('abi-compliance-checker<2.2')
+source=(${pkgname}-${pkgver}.tar.gz::https://github.com/lvc/${pkgname}/archive/${pkgver}.tar.gz)
+md5sums=('b4540063202fe7bd1d4fee58b31a2b22')
+sha1sums=('46b3ebf9fbd42d48aa33bde1b5d84638b6893480')
+sha256sums=('ef63201368e0d76a29d2f7aed98c488f6fb71898126762d65baed1e762988083')
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -d "${pkgdir}/usr"
+ perl Makefile.pl -install --prefix=/usr --destdir="${pkgdir}"
+}