summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Andersson2017-07-16 00:23:05 +0200
committerMaxim Andersson2017-07-16 00:23:05 +0200
commit7878bd4201f0245e2b96a3fed194843e6098c12f (patch)
treef8b86b7b888f6a524dc9319372eaec81225222eb /PKGBUILD
parent45c409bf1976581804d7a3a2c6f9a45455d5715f (diff)
downloadaur-7878bd4201f0245e2b96a3fed194843e6098c12f.tar.gz
Add gconf to depends array and add devdir flag to npm
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 401e286b3875..562aae59efc6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,12 @@
pkgname=abricotine
pkgver=0.5.0
-pkgrel=1
+pkgrel=2
pkgdesc="A markdown editor with inline preview"
arch=('i686' 'x86_64')
url="http://abricotine.brrd.fr"
license=('GPL3')
+depends=('gconf')
makedepends=('npm')
source=("https://github.com/brrd/${pkgname}/archive/${pkgver}.tar.gz"
"${pkgname}.desktop")
@@ -16,7 +17,7 @@ sha256sums=('6e84be88c8b4d791024d45ba6310374d7dd50a5a36f8dd472d62c50412a2f899'
build() {
cd "${srcdir}/${pkgname^}-${pkgver}"
- npm install --cache ../cache
+ npm install --cache ../cache --devdir="${srcdir}/devdir"
npm run packager
}