summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFrank Seifferth2019-09-17 11:22:15 +0100
committerFrank Seifferth2019-09-17 11:22:15 +0100
commita0847022908e4b1460b001c0d391affe70617153 (patch)
treeacb858947714db8f8f79f1a599134bae7194588c /PKGBUILD
parent7f4fdab76bccfa831b11d3c1022349d57c54d29a (diff)
downloadaur-a0847022908e4b1460b001c0d391affe70617153.tar.gz
Workaround for outdated dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b73d8c19fcf..92e8c709bdfd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=abricotine
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="A markdown editor with inline preview"
arch=('x86_64')
url="http://abricotine.brrd.fr"
@@ -15,6 +15,13 @@ source=("${pkgname}-${pkgver}.tar.gz::https://github.com/brrd/${pkgname}/archive
sha256sums=('03bc7735be08ceacb412b1fd96d13b8ba14eda629cd8b6c705e8421ee7875442'
'164d0042ffe461ca0418709a59be29b433055589b661be4d6555c07df42b383c')
+prepare() {
+ # This is an ugly workaround for fixing outdated dependencies.
+ cd "${srcdir}/${pkgname^}-${pkgver}"
+ sed -i 's,"\([0-9]\+\.[0-9]\+\.[0-9]\+"\),"^\1,g' package.json
+ sed -i 's,"version": "^0.7.0","version": "0.7.0",g' package.json
+}
+
build() {
cd "${srcdir}/${pkgname^}-${pkgver}"