summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAleksandar Trifunovic2020-11-16 15:07:09 +0100
committerAleksandar Trifunovic2020-11-16 15:07:09 +0100
commit3e814e0520ec1747ab20236ffcff90d4834d7d9a (patch)
tree678db311d33fcdc885b49ba94792a39d4159a719 /PKGBUILD
parentef80e4b7e187d80e853c54bc770d96d3f2aea570 (diff)
downloadaur-3e814e0520ec1747ab20236ffcff90d4834d7d9a.tar.gz
change supported architectures
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac1076ddaf13..15b95dbd0177 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,10 +3,10 @@
pkgname=abseil-cpp-git
_pkgname="${pkgname%-git}"
-pkgver=r268.f951790
+pkgver=r629.0bbebc8
pkgrel=1
pkgdesc='An open-source collection of C++ code to augment the C++ standard library'
-arch=('i686' 'x86_64')
+arch=('x86_64' 'i686' 'arm' 'aarch64' 'ppc')
url='https://github.com/abseil/abseil-cpp'
license=('Apache')
makedepends=('cmake' 'git')
@@ -29,8 +29,8 @@ prepare() {
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DABSL_RUN_TESTS=ON \
- -DABSL_USE_GOOGLETEST_HEAD=ON
+ -DABSL_RUN_TESTS=OFF \
+ -DABSL_USE_GOOGLETEST_HEAD=OFF
}
build() {
@@ -38,18 +38,12 @@ build() {
cmake --build build
}
-check() {
- cd "$_pkgname"
- cmake --build build -- test ARGS="$MAKEFLAGS"
-}
+# check() {
+# cd "$_pkgname"
+# cmake --build build -- test
+# }
package() {
cd "$_pkgname"
-
- mkdir -p "$pkgdir/usr/include"
- cp -a absl "$pkgdir/usr/include/absl"
- mkdir "${pkgdir}/usr/lib/"
- find build/absl -name "*.a" -exec cp {} "${pkgdir}/usr/lib" \;
-
- # cmake --build build -- DESTDIR="$pkgdir" install
+ cmake --build build -- DESTDIR="$pkgdir" install
}