summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracedron2021-07-12 19:26:58 +0300
committeracedron2021-07-12 19:26:58 +0300
commite716ace70445e2ea5ba0377a4580edd692495535 (patch)
tree8462a89c888cb054ef341942471f22e907d0a422 /PKGBUILD
parentb6773a0effddeb8a9893038dd9efefc4432a097f (diff)
downloadaur-e716ace70445e2ea5ba0377a4580edd692495535.tar.gz
resolve conflicts
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD42
1 files changed, 28 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68ec1cf2fc28..559408f44c60 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,39 @@
# Maintainer: acedron <acedrons@yahoo.co.jp>
pkgname=abstouch-nux
-pkgver=1.3.0
+pkgver=1.0.0
pkgrel=1
-pkgdesc="An absolute touchpad input client for GNU/Linux."
-arch=('any')
-url="https://github.com/acedron/${pkgname}"
-license=('GPL3' 'LGPL3')
+pkgdesc="Makes your touchpad work like a graphics tablet on GNU/Linux."
+arch=('i686' 'pentium4' 'x86_64' 'arm' 'armv7h' 'armv6h' 'aarch64')
+url="https://github.com/acedron/abstouch-nux"
+license=('GPL3')
+depends=(
+ 'libxi'
+ 'libx11'
+ 'xf86-input-libinput'
+)
makedepends=(
- 'rust'
- 'gcc'
+ 'cmake>=3.9.0'
+ 'gcc'
)
-source=("${pkgname}-${pkgver}.tar.xz::${url}/releases/download/v${pkgver}/${pkgname}-${pkgver}.tar.xz")
-md5sums=('SKIP')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/acedron/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('0722f777d735b816889a29e79e300aabbc31986f191f1e3e081c7a38464c7dbc')
build() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- make build
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake \
+ -B build \
+ -DCMAKE_BUILD_TYPE:STRING='None' \
+ -DCMAKE_INSTALL_PREFIX:PATH='/usr'
+ make -C build all
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make -C build test
}
package() {
- cd "${srcdir}/${pkgname}-${pkgver}"
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- make DESTDIR="${pkgdir}" PREFIX="/usr" install
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make -C build DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}