summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorM0Rf302023-01-04 13:04:49 +0100
committerM0Rf302023-01-04 13:04:49 +0100
commitf1090aabe9c3199c930442621b87e1599ff7a117 (patch)
tree6b0011204e9c35dc1ad86688f25637c0a220223d /PKGBUILD
parentb3855483889512bad32ba06f4308386c62f0e6d6 (diff)
downloadaur-abyss-engine-git.tar.gz
abyss-engine-git: update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e68c973fe85..e2d75d8f69d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: robertfoster
pkgname=abyss-engine-git
-pkgver=r248.7f266ae
+pkgver=r254.bf1feb3
pkgrel=1
pkgdesc="A game engine designed to run games similar to 2000's style ARPGs such as Diablo II"
arch=('i686' 'x86_64')
url="https://github.com/AbyssEngine/AbyssEngine"
license=('GPL3')
depends=('argh' 'cppzmq' 'ffmpeg' 'lua' 'lua-lpeg' 'sdl2_ttf' 'spdlog' 'sol2')
-makedepends=('cmake' 'git' "gtest")
+makedepends=('cmake' 'git' 'gtest' 'luarocks')
provides=("${pkgname%-git}" "opendiablo2-git")
conflicts=("${pkgname%-git}" "opendiablo2-git")
source=("${pkgname%-git}::git+${url}"
@@ -57,4 +57,7 @@ package() {
install -Dm755 "${srcdir}/opendiablo2.sh" \
"${pkgdir}/usr/bin/opendiablo2"
+
+ # remove unneeded dotfiles
+ find "${pkgdir}/usr/share/opendiablo2" -iname ".*" -prune -exec rm -r '{}' \;
}