summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSigmund2015-07-08 23:38:56 +0100
committerSigmund2015-07-08 23:38:56 +0100
commit3f278d211969224fa93f39c4b5ce0b88fbb1a02f (patch)
tree1e03d5d1d9da441172e0e737eb6191041f5e838d /PKGBUILD
downloadaur-3f278d211969224fa93f39c4b5ce0b88fbb1a02f.tar.gz
First commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5ab1adda35d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Sigmund Vestergaard <sigmundv at gmail dot com>
+# Contributor: MacCyber <jonas.enge at gmail dot com>
+# Contributor: Doug Newgard <scimmia22 at outlook dot com>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Antti Hautaniemi <an7oine at me com>
+
+pkgname=acestream-engine
+pkgver=3.0.5.1
+pkgrel=1
+_ubuntuver=14.04
+pkgdesc="ACE Stream engine"
+arch=('x86_64')
+url="http://acestream.org/"
+license=('unknown')
+depends=('python2-setuptools' 'python2-xlib' 'python2-m2crypto' 'python2-apsw')
+optdepends=('libappindicator-gtk2: GTK+ gui support')
+install='acestream-engine.install'
+source=('acestream-engine.service'
+ "http://dl.acestream.org/ubuntu/${_ubuntuver%.*}/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH.tar.gz")
+sha256sums=('b9863a9dd3ee6d41d18475f5f539107fe81a573f45ca1cb98013441f955f1af0'
+ '5dbfc20af2ebe890f14f1e2a7565e45f53654e7888b389af8797cfaee9cda397')
+
+package() {
+ cd "$srcdir/acestream_${pkgver}_ubuntu_${_ubuntuver}_$CARCH"
+ install -Dm755 acestreamengine "$pkgdir/usr/bin/acestreamengine"
+ install -d "$pkgdir/usr/share/acestream/"
+ cp -a data lib "$pkgdir/usr/share/acestream/"
+ install -Dm644 "$srcdir/acestream-engine.service" "$pkgdir/usr/lib/systemd/system/acestream-engine.service"
+}