summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonian Guveli2015-10-24 01:15:53 +0300
committerJonian Guveli2015-10-24 01:15:53 +0300
commitcb53871df05e83f89aa51ee6df6df06f7512fbcf (patch)
treeebd51557da0f6ff922c166b9a9e3d1819c91912f /PKGBUILD
downloadaur-cb53871df05e83f89aa51ee6df6df06f7512fbcf.tar.gz
first release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5ba1bd78f44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Jonian Guveli <https://github.com/jonian/>
+pkgname=acestream-launcher
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Acestream Launcher allows you to open Acestream links with a Media Player of your choice"
+arch=('any')
+url="https://github.com/jonian/acestream-launcher"
+license=('GPL')
+groups=()
+depends=('python2-psutil' 'python2-pexpect' 'acestream-engine')
+makedepends=()
+optdepends=('vlc')
+provides=('acestream-launcher')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=(https://github.com/jonian/acestream-launcher/archive/v$pkgver.tar.gz)
+noextract=()
+md5sums=('SKIP')
+
+package() {
+ mkdir -p "$pkgdir/opt"
+ mkdir -p "$pkgdir/usr/bin"
+ mkdir -p "$pkgdir/usr/share/applications"
+
+ cp -a "$srcdir/$pkgname-$pkgver" "$pkgdir/opt/acestream-launcher"
+
+ update-desktop-database "$pkgdir/opt/acestream-launcher"
+
+ ln -s "/opt/acestream-launcher/acestream-launcher.py" "$pkgdir/usr/bin/acestream-launcher"
+ mv "$pkgdir/opt/acestream-launcher/acestream-launcher.desktop" "$pkgdir/usr/share/applications/acestream-launcher.desktop"
+}