summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12017-08-22 00:42:23 +0800
committerChocobo12017-08-22 00:49:36 +0800
commit7107b1ce70fab5f603f78b31695f9d92c2e4aefa (patch)
tree9b5044864cc28d8afd8fcd584601abcf6c20f9cb /PKGBUILD
downloadaur-7107b1ce70fab5f603f78b31695f9d92c2e4aefa.tar.gz
newpkg: acl-git 2.2.52.r53.gfa5f683-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..daf6af70ff64
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=acl-git
+pkgver=2.2.52.r53.gfa5f683
+pkgrel=1
+pkgdesc="Commands for manipulating POSIX access control lists"
+arch=('i686' 'x86_64')
+url="https://savannah.nongnu.org/projects/acl"
+license=('GPL' 'LGPL')
+depends=('glibc' 'attr')
+makedepends=('git')
+provides=('acl' 'xfsacl')
+conflicts=('acl' 'xfsacl')
+replaces=('xfsacl')
+options=('staticlibs')
+source=("git+https://git.savannah.gnu.org/git/acl.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "acl"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "acl"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "acl"
+
+ make check
+}
+
+package() {
+ cd "acl"
+
+ make DESTDIR="$pkgdir" install
+}