summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Hirst2015-08-24 19:32:17 +0200
committerAdam Hirst2015-08-24 19:32:17 +0200
commit15a887e3861c18cd3fa75e2171ba666dc0970b9c (patch)
tree24471c01b74d7e2d62b2f1e31c83f8769e71a5b5 /PKGBUILD
downloadaur-15a887e3861c18cd3fa75e2171ba666dc0970b9c.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0dcde55002b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# $Id$
+# Maintainer: Adam Hirst <adam@aphirst.karoo.co.uk>
+# Maintainer: Zuyi Hu <hzy0668808@gmail.com>
+# Contributor: Maxime Gauduin <alucryd@gmail.com>
+# Contributor: mortzu <me@mortzu.de>
+# Contributor: fnord0 <fnord0@riseup.net>
+
+pkgname=acpi_call-ck
+pkgver=1.1.0
+pkgrel=15
+_extramodules=extramodules-4.0-ck
+pkgdesc='A linux-ck kernel module that enables calls to ACPI methods through /proc/acpi/call'
+arch=('i686' 'x86_64')
+url="http://github.com/mkottman/${pkgname%-*}"
+license=('GPL')
+depends=('linux-ck>=4.1' 'linux-ck<4.2')
+makedepends=('linux-ck-headers>=4.1' 'linux-ck-headers<4.2')
+provides=("${pkgname%-*}")
+install="${pkgname}.install"
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('d0d14b42944282724fca76f57d598eed794ef97448f387d1c489d85ad813f2f0')
+
+build() {
+ cd ${pkgname%-*}-${pkgver}
+
+ sed -i '9s/acpi/linux/' acpi_call.c
+
+ _kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
+
+ make KVERSION="${_kernver}"
+}
+
+package() {
+ cd ${pkgname%-*}-${pkgver}
+
+ install -dm 755 "${pkgdir}"/usr/lib/{modules/${_extramodules},modules-load.d}
+ install -m 644 ${pkgname%-*}.ko "${pkgdir}"/usr/lib/modules/${_extramodules}/
+ gzip "${pkgdir}"/usr/lib/modules/${_extramodules}/${pkgname%-*}.ko
+ echo ${pkgname%-*} > "${pkgdir}"/usr/lib/modules-load.d/${pkgname}.conf
+
+ install -dm 755 "${pkgdir}"/usr/share/${pkgname}
+ cp -dr --no-preserve='ownership' {examples,support} "${pkgdir}"/usr/share/${pkgname}/
+}
+
+# vim: ts=2 sw=2 et:
+