summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Straube2016-05-11 22:03:29 +0200
committerMichael Straube2016-05-11 22:03:29 +0200
commit0a0913d360f5c7fa4da140f52c933c0d5f07a875 (patch)
tree595b19538bfdf61f8ee75180ab6bc22c3064c094 /PKGBUILD
downloadaur-0a0913d360f5c7fa4da140f52c933c0d5f07a875.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de6f69e3f911
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Michael Straube <m.s.online gmx.de>
+
+pkgname=actiona
+pkgver=3.9.1
+pkgrel=1
+pkgdesc="A task automation tool that allows you to create and execute action lists"
+arch=('i686' 'x86_64')
+url="https://wiki.actiona.tools"
+license=('GPL3')
+depends=('qt5-script' 'qt5-xmlpatterns' 'qt5-x11extras' 'qt5-multimedia' 'opencv' 'libnotify')
+makedepends=('qt5-tools' 'boost')
+source=("https://github.com/Jmgr/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('46ddc28a6cc4bb951a1ea4bd65832e7cb2f10d4397e18475bb872c83b5c60188')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ qmake -r PREFIX=/usr
+ make && make locale_release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make INSTALL_ROOT="$pkgdir" install
+}