summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew O'Neill2018-05-26 19:37:07 -0400
committerAndrew O'Neill2018-05-26 19:37:07 -0400
commite1ff6be87d4e2a89cf851c726e5053816bad567c (patch)
tree4876342605d194a9971bf80eccbc96ceadbf8622 /PKGBUILD
parent9bc7a103cec62181aac9b61d8ff8bcbd972af3f6 (diff)
downloadaur-e1ff6be87d4e2a89cf851c726e5053816bad567c.tar.gz
Add patch to properly build against Qt 5.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a4984513417..92c882d1659a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,23 @@
pkgname=actiona
pkgver=3.9.4
-pkgrel=1
+pkgrel=2
pkgdesc="A task automation tool that allows you to create and execute action lists"
arch=('x86_64')
url="https://wiki.actiona.tools"
license=('GPL3')
depends=('qt5-script' 'qt5-xmlpatterns' 'qt5-x11extras' 'qt5-multimedia' 'opencv' 'libnotify')
makedepends=('qt5-tools' 'boost')
-source=("https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('e2537852548d34fa7407324b40b000ef30d8e5deef310ece7a4f938b6be3f185')
+source=("https://github.com/Jmgr/${pkgname}/archive/v${pkgver}.tar.gz"
+ "${pkgname}.patch")
+sha256sums=('e2537852548d34fa7407324b40b000ef30d8e5deef310ece7a4f938b6be3f185'
+ 'c95371a42dcc2186f06142bd08bce9d65e5c700b51bff8bbb939d5ef25ead899')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+
+ patch -p1 -i ../${pkgname}.patch
+}
build() {
cd "${pkgname}-${pkgver}"