summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTucker Boniface2019-02-03 18:11:15 -0800
committerTucker Boniface2019-02-03 18:11:15 -0800
commit2da82715f5d6dfaaeb06853772b6a501fa6f2205 (patch)
tree2f3c9ecbd89a399030e2c2001551b02f3684024f /PKGBUILD
parente89386b46c6ee22ea4e70d4ca65eedd21c5ae577 (diff)
downloadaur-2da82715f5d6dfaaeb06853772b6a501fa6f2205.tar.gz
overhaul pkgbuild and update to 2.0.0-M3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 24 insertions, 34 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 068f9a3e5b7e..18108b3cb9c5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,56 +1,46 @@
-# $Id$
-# Maintainer: Tejuswi Vaghjee <tejvghj at gmail dot com>
+# Maintainer: Tucker Boniface <tucker@boniface.tech>
+# Contributor: Tejuswi Vaghjee <tejvghj at gmail dot com>
# Contributor: Sven-Hendrik Haase <sh at lutzhaase dot com>
# Contributor: Jaroslaw Swierczynski <swiergot at aur dot archlinux dot org>
# Contributor: Roman Kyrylych <Roman dot Kyrylych at gmail dot com>
# Contributor: Rabyte <rabyte at gmail dot com>
pkgname=actionfps
-gitname=ActionFPS-Game-version_1000
-pkgver=1000
+pkgver=2.0.0_M3
pkgrel=1
+epoch=1
pkgdesc="A game based on the open-source AssaultCube first-person shooter (FPS)"
arch=('i686' 'x86_64')
url="https://actionfps.com"
license=('ZLIB' 'custom')
depends=('sdl' 'sdl_mixer' 'sdl_image' 'openal' 'zlib' 'gcc-libs' 'libgl' 'glu' 'curl')
makedepends=('mesa' 'clang')
-provides=('actionfps')
-source=("https://github.com/ActionFPS/ActionFPS-Game/archive/version_1000.tar.gz"
- 'actionfps-gcc6-1.patch'
+source=("https://github.com/ActionFPS/ActionFPS-Game/releases/download/${pkgver//_/-}/ActionFPS.tar.bz2"
+ 'https://raw.githubusercontent.com/ActionFPS/ActionFPS-Game/master/docs/package_copyrights.txt'
+ 'actionfps-cubedir.patch'
'actionfps'
'actionfps-server'
'actionfps.desktop'
'actionfps.png')
-md5sums=('32dad06e74202dea378efff732c0c249'
- 'ac0b864edc62900fecaa547fd456645e'
- '3273bc8220f2e50e39e8076f06d8144d'
- 'd00249969554bd600f5a39187a10c5d4'
- '22aaf111f2bce517000baaa375ba9321'
- 'f7da6cb5df462439693b4c2560223a97')
-
+sha512sums=('352d7805c321a621200e6c50de289dfb81a81c516df9fc8656f5b0ea26684d56a87da843a61d1e52cdea4e48c6b962adb0dd9fad6e259cadf75c1121a22b75f6'
+ '44d9a06c48fa98c80873c3aaa3c3639ad5ce2251c8ab606178e8b8295af518df314e936f24e0ebd5796466044591477d323026e17ce43cdd53207552b5d45872'
+ '0a337b67b6b8ec4d22a9b74c71f4f196b52c5a9e6d5f6fd1616efb8c99158839aed8aaf22268df3db84aeaa1a5254240102136a48e7f8511fd96416c12abb356'
+ '9b2c802657d0d4cc25be98eb72c7d6a396c7a1abf5e5d6640849eb43db845bde0c4bac7c21edfefea526594faef805a4e1d218c0454191e6ff0f4a93d12a6187'
+ '9a480f56053155fd51a5574ab4cf6a8d31479c35ba8ce5523e561d021f8d4198a505e2340572cd0f6e6d6c9deb99aaec5025518f366b5db7671f337018a11437'
+ '751376e2820a3a5d590f4f323e414d5a40b34137ce9988a9dfe9aa857ba00ec3d721c323be7497e7d3f5002de0746c3af02f557029977247d0e72b16bdb6cbb8'
+ '30b0e533939831f90695641632b70dbdd3adbab09fb89af24d8eb1fed7056942124775c1f8b2bb22b852800eb6d9749ed54b5fb6661c283ea590b519acbd1975')
prepare() {
- cd ${gitname}
- # Fix build with GCC 6
- patch -p1 -i ../actionfps-gcc6-1.patch
-}
-
-build() {
- cd "${gitname}/source/src"
- make
+ cd "$srcdir/ActionFPS"
+ ./install-packages.sh
}
package() {
- cd "${gitname}/source/src"
- install -Dm755 ac_client ${pkgdir}/usr/bin/actionfps_client
- install -Dm755 ac_server ${pkgdir}/usr/bin/actionfps_server
-
- cd ${srcdir}/${gitname}
- mkdir -p ${pkgdir}/usr/share/actionfps
- cp -rf config packages docs ${pkgdir}/usr/share/actionfps
- install -Dm644 ${srcdir}/actionfps.png ${pkgdir}/usr/share/pixmaps/actionfps.png
- install -Dm644 ${srcdir}/actionfps.desktop ${pkgdir}/usr/share/applications/actionfps.desktop
- install -Dm644 docs/package_copyrights.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- install -Dm755 ${srcdir}/actionfps ${pkgdir}/usr/bin/actionfps
- install -Dm755 ${srcdir}/actionfps-server ${pkgdir}/usr/bin/actionfps-server
+ cd "$srcdir"
+ install -m755 -d "$pkgdir/usr/share/actionfps"
+ cp -r ActionFPS/* "$pkgdir/usr/share/actionfps"
+ install -Dm644 actionfps.png ${pkgdir}/usr/share/pixmaps/actionfps.png
+ install -Dm644 actionfps.desktop ${pkgdir}/usr/share/applications/actionfps.desktop
+ install -Dm644 package_copyrights.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm755 actionfps ${pkgdir}/usr/bin/actionfps
+ install -Dm755 actionfps-server ${pkgdir}/usr/bin/actionfps-server
}