summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-02-04 13:32:55 -0500
committerPatrick Northon2021-02-04 13:32:55 -0500
commit4c3d8e99b8165561215828c912afa1ef23be4fee (patch)
tree293e6c5ab92554c282427951103ecc3e75e58cb3 /PKGBUILD
parent2da82715f5d6dfaaeb06853772b6a501fa6f2205 (diff)
downloadaur-4c3d8e99b8165561215828c912afa1ef23be4fee.tar.gz
Update to new version.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 23 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 18108b3cb9c5..ed2c7d0940a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,46 +1,47 @@
-# Maintainer: Tucker Boniface <tucker@boniface.tech>
-# Contributor: Tejuswi Vaghjee <tejvghj at gmail dot com>
+# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
+# Contributor: Tucker Boniface <tucker@boniface.tech>
+# Contributor: Tejuswi Vaghjee <tejvghj at gmail dot com>
# Contributor: Sven-Hendrik Haase <sh at lutzhaase dot com>
# Contributor: Jaroslaw Swierczynski <swiergot at aur dot archlinux dot org>
# Contributor: Roman Kyrylych <Roman dot Kyrylych at gmail dot com>
# Contributor: Rabyte <rabyte at gmail dot com>
pkgname=actionfps
-pkgver=2.0.0_M3
+pkgver=1.2.0.2
pkgrel=1
-epoch=1
pkgdesc="A game based on the open-source AssaultCube first-person shooter (FPS)"
arch=('i686' 'x86_64')
url="https://actionfps.com"
license=('ZLIB' 'custom')
-depends=('sdl' 'sdl_mixer' 'sdl_image' 'openal' 'zlib' 'gcc-libs' 'libgl' 'glu' 'curl')
+depends=('sdl' 'sdl_mixer' 'sdl_image' 'openal' 'zlib' 'gcc-libs' 'libgl' 'glu' 'curl' 'libogg' 'libvorbis')
makedepends=('mesa' 'clang')
-source=("https://github.com/ActionFPS/ActionFPS-Game/releases/download/${pkgver//_/-}/ActionFPS.tar.bz2"
- 'https://raw.githubusercontent.com/ActionFPS/ActionFPS-Game/master/docs/package_copyrights.txt'
+source=("https://github.com/assaultcube/AC/releases/download/v${pkgver}/AssaultCube_v${pkgver}.tar.bz2"
'actionfps-cubedir.patch'
'actionfps'
'actionfps-server'
'actionfps.desktop'
'actionfps.png')
-sha512sums=('352d7805c321a621200e6c50de289dfb81a81c516df9fc8656f5b0ea26684d56a87da843a61d1e52cdea4e48c6b962adb0dd9fad6e259cadf75c1121a22b75f6'
- '44d9a06c48fa98c80873c3aaa3c3639ad5ce2251c8ab606178e8b8295af518df314e936f24e0ebd5796466044591477d323026e17ce43cdd53207552b5d45872'
- '0a337b67b6b8ec4d22a9b74c71f4f196b52c5a9e6d5f6fd1616efb8c99158839aed8aaf22268df3db84aeaa1a5254240102136a48e7f8511fd96416c12abb356'
- '9b2c802657d0d4cc25be98eb72c7d6a396c7a1abf5e5d6640849eb43db845bde0c4bac7c21edfefea526594faef805a4e1d218c0454191e6ff0f4a93d12a6187'
- '9a480f56053155fd51a5574ab4cf6a8d31479c35ba8ce5523e561d021f8d4198a505e2340572cd0f6e6d6c9deb99aaec5025518f366b5db7671f337018a11437'
+sha512sums=('50b7b466968ab7570889cc6c4d13b221cc8c5c0d24255f42aa4d0eafb92e186b1b4fb737308691fcb786d07cbfb74622b73967e42a96278e710796790c469ac3'
+ '4dae912c01aa50953e3859bacb8ba57c09e0ba22c54eebcc2a6df9223cdba2b14fd2337842ed40ad1850cf8cd380b4a0453dc00d16f83fc145dcc22408429cbf'
+ '6124c36968521f395aa43d1e01d0e7f939259b650a24bf639b18bb2adaa329309d14c25ad66e747274ba18e07f5c7d29a95b72f4922565a4ee36a1de61381ff6'
+ '621c919fdc766eac79cfaeee11ddb402a02901fad33f27ccdb2bd7404e376092e195fca4a26b82cb21bede8fe7ccf229936123bb5a945d3f89eab9aa3b9bf2af'
'751376e2820a3a5d590f4f323e414d5a40b34137ce9988a9dfe9aa857ba00ec3d721c323be7497e7d3f5002de0746c3af02f557029977247d0e72b16bdb6cbb8'
'30b0e533939831f90695641632b70dbdd3adbab09fb89af24d8eb1fed7056942124775c1f8b2bb22b852800eb6d9749ed54b5fb6661c283ea590b519acbd1975')
+
prepare() {
- cd "$srcdir/ActionFPS"
- ./install-packages.sh
+ cd "AssaultCube_v${pkgver}"
+ rm -rf "source/lib"
+ patch -uN < "../actionfps-cubedir.patch"
+ cd "source/src"
+ make
}
package() {
- cd "$srcdir"
- install -m755 -d "$pkgdir/usr/share/actionfps"
- cp -r ActionFPS/* "$pkgdir/usr/share/actionfps"
- install -Dm644 actionfps.png ${pkgdir}/usr/share/pixmaps/actionfps.png
- install -Dm644 actionfps.desktop ${pkgdir}/usr/share/applications/actionfps.desktop
- install -Dm644 package_copyrights.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- install -Dm755 actionfps ${pkgdir}/usr/bin/actionfps
- install -Dm755 actionfps-server ${pkgdir}/usr/bin/actionfps-server
+ install -m755 -d "$pkgdir/usr/share/games/actionfps"
+ cp -r "AssaultCube_v${pkgver}"/* "$pkgdir/usr/share/games/actionfps"
+ install -Dm644 actionfps.png "${pkgdir}/usr/share/pixmaps/actionfps.png"
+ install -Dm644 actionfps.desktop "${pkgdir}/usr/share/applications/actionfps.desktop"
+ install -Dm644 "AssaultCube_v${pkgver}/docs/package_copyrights.txt" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm755 actionfps "${pkgdir}/usr/bin/actionfps"
+ install -Dm755 actionfps-server "${pkgdir}/usr/bin/actionfps-server"
}