summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcel Röthke2018-10-03 14:10:55 +0200
committerMarcel Röthke2018-10-03 14:10:55 +0200
commit34e379013076b42bea1ff31eed6ddc7882b99fe7 (patch)
treea5b75719f1d5a37d46451e9eab3a66fe6d4b034f /PKGBUILD
parent5ad73df1cbd8682f62975da311e528c327bb2b26 (diff)
downloadaur-34e379013076b42bea1ff31eed6ddc7882b99fe7.tar.gz
upgpkg: actor-framework 0.16.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 39 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a158ef7c398d..80c9c4d1aadf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,62 @@
# Maintainer: Mirco Tischler <mt-ml at gmx dot de>
+# Contributor: Mirco Tischler <mt-ml at gmx dot de>
pkgname=actor-framework
-pkgver=0.14.4
+pkgver=0.16.0
pkgrel=1
pkgdesc="An Open Source Implementation of the Actor Model in C++"
arch=(i686 x86_64)
url="http://actor-framework.org"
license=('custom:"BSD-3-Clause"',
'custom:"Boost Software License"')
-depends=('boost' 'libcl')
-makedepends=('cmake' 'valgrind' 'gperftools' 'protobuf' 'opencl-headers')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/actor-framework/${pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('7e77b1edc708ac66be3ab2ba29506681458422e59a2e1b3cd801152ba345fb00')
+depends=(opencl-driver)
+makedepends=('cmake' 'opencl-headers' 'git' 'python' 'opencl-icd-loader' 'chrpath')
+optdepends=(
+ 'python: python binding'
+ 'opencl-icd-loader: opencl support'
+ 'openssl: openssl support'
+ )
+
+source=(
+ "git+https://github.com/actor-framework/actor-framework#commit=903f801cc479a1dcbc9cc7a0ebdf5f920b981f0c"
+ "git+https://github.com/pybind/pybind11.git"
+ )
+sha256sums=(
+ 'SKIP'
+ 'SKIP'
+ )
+
+prepare(){
+ cd ${pkgname}
+ git submodule init libcaf_python/third_party/pybind
+ git config submodule.libcaf_python/third_party/pybind.url "${srcdir}/pybind11"
+ git submodule update
+
+ # Disable opencl test, it can't work in a clean chroot
+ rm libcaf_opencl/test/opencl.cpp
+
+
+ LDFLAGS=$LDFLAGS CXXFLAGS=$CXXFLAGS \
+ ./configure \
+ --prefix=/usr \
+ --no-examples
+}
build() {
- cd ${pkgname}-${pkgver}
- # reset CXXFLAGS: cmake will overwrite the project's CXXFLAGS with makepkg's custom flags.
- CXXFLAGS='' ./configure --prefix=/usr
+ cd ${pkgname}
make
}
check() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}
make test
}
package() {
- cd ${pkgname}-${pkgver}
+ cd ${pkgname}
make DESTDIR="${pkgdir}" install
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -D -m644 LICENSE_ALTERNATIVE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE_ALTERNATIVE"
+
+ chrpath -d "${pkgdir}/usr/bin/caf-python"
}