summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMarcel Röthke2019-11-13 13:41:00 +0100
committerMarcel Röthke2019-11-13 13:41:00 +0100
commit3b1538adfbe158c36a2577bda12a1ace2a0b8c09 (patch)
tree24b1da603072148943ae84bbd49eba2098a64389 /PKGBUILD
parent8d413bc1538fbef12c96046445294406d64d4f7e (diff)
downloadaur-3b1538adfbe158c36a2577bda12a1ace2a0b8c09.tar.gz
upgpkg: actor-framework 0.17.3-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 11 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e4b1b7792b4..4a70fc53416b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Mirco Tischler <mt-ml at gmx dot de>
pkgname=actor-framework
-pkgver=0.17.2
+pkgver=0.17.3
pkgrel=1
pkgdesc="An Open Source Implementation of the Actor Model in C++"
arch=(i686 x86_64)
@@ -10,21 +10,28 @@ url="http://actor-framework.org"
license=('custom:"BSD-3-Clause"'
'custom:"Boost Software License"')
depends=()
-makedepends=('cmake' 'opencl-headers' 'git' 'opencl-icd-loader')
+makedepends=('cmake' 'opencl-headers' 'git' 'python' 'opencl-icd-loader')
optdepends=(
+ 'python: caf-python'
+ 'ipython: caf-python'
'opencl-icd-loader: opencl support'
'openssl: openssl support'
)
source=(
- "git+https://github.com/actor-framework/actor-framework#commit=4da751ab7a79bcdc6e9dd2157b9b5c5c6814e26d"
+ "git+https://github.com/actor-framework/actor-framework#commit=b05a4b7b2a6f59b0508db84ea68e5ada2224f904"
+ "git+https://github.com/pybind/pybind11.git"
)
sha256sums=(
'SKIP'
+ 'SKIP'
)
prepare(){
cd ${pkgname}
+ git submodule init libcaf_python/third_party/pybind
+ git config submodule.libcaf_python/third_party/pybind.url "${srcdir}/pybind11"
+ git submodule update
# Disable opencl test, it can't work in a clean chroot
rm libcaf_opencl/test/opencl.cpp
@@ -33,8 +40,7 @@ prepare(){
LDFLAGS=$LDFLAGS CXXFLAGS=$CXXFLAGS \
./configure \
--prefix=/usr \
- --no-examples \
- --no-python
+ --no-examples
}
build() {