summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMirco Tischler2015-06-08 18:49:01 +0200
committerMirco Tischler2015-06-08 18:49:19 +0200
commitd5213385036fceb52e4744b83b3debd92fa92104 (patch)
tree0ede21430f4d9687c91e911f3c64877be191da99 /PKGBUILD
downloadaur-d5213385036fceb52e4744b83b3debd92fa92104.tar.gz
actor-framework: version 0.13.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a7a9d358160
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Mirco Tischler <mt-ml at gmx dot de>
+
+pkgname=actor-framework
+pkgver=0.13.2
+pkgrel=1
+pkgdesc="An Open Source Implementation of the Actor Model in C++"
+arch=(i686 x86_64)
+url="http://actor-framework.org"
+license=('custom:"BSD-3-Clause"',
+ 'custom:"Boost Software License"')
+depends=('boost' 'libcl')
+makedepends=('cmake' 'valgrind' 'gperftools' 'protobuf' 'opencl-headers')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/actor-framework/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('3ccf7e469740e750eef31f14b965b00f7b6e3a89b05086a088ca905b3b1a04e6')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ # reset CXXFLAGS: cmake will overwrite the project's CXXFLAGS with makepkg's custom flags.
+ CXXFLAGS='' ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd ${pkgname}-${pkgver}
+ make test
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE_ALTERNATIVE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE_ALTERNATIVE"
+}