summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRod Kay2023-06-16 21:40:06 +1000
committerRod Kay2023-06-16 21:40:06 +1000
commitfef71c8da26095a4a54066003a8cb90e8089a9c1 (patch)
tree11d614f1b763d10ef013d160102b5e4f6e3fe67d /PKGBUILD
parent24c77e41426a399f1bd7c4d69fab477786e042ec (diff)
downloadaur-fef71c8da26095a4a54066003a8cb90e8089a9c1.tar.gz
Don't install templates2ada and templatespp from templates_parser, as these are now owned by the new templates_parser package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 34 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d5f06170e0a..578777ec35ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,21 @@ pkgname=ada-web-server
epoch=1
pkgver=23.0.0
pkgrel=1
-pkgdesc="A complete embeddable web application framework for Ada."
+pkgdesc='A complete embeddable web application framework for Ada.'
arch=(i686 x86_64)
url=http://libre.adacore.com/tools/aws
license=(GPL)
groups=(gcc-ada)
-depends=(gnatcoll-core openssl python)
-makedepends=(gprbuild texlive-bin texlive-core texlive-latexextra python-sphinx)
+depends=(gnatcoll-core
+ openssl
+ python)
+makedepends=(gprbuild
+ texlive-bin
+ texlive-core
+ texlive-latexextra
+ python-sphinx)
provides=(aws)
@@ -28,20 +34,20 @@ prepare()
cd $srcdir/aws-$pkgver
rmdir templates_parser
- ln -s "$srcdir/templates-parser-$pkgver" templates_parser
+ ln -s $srcdir/templates-parser-$pkgver templates_parser
}
build()
{
- cd "$srcdir/aws-$pkgver/templates_parser"
+ cd $srcdir/aws-$pkgver/templates_parser
PRJ_BUILD=Release make DEBUG=false prefix=/usr setup
PRJ_BUILD=Release make DEBUG=false build
- cd docs
- mkdir -p build
- make -j1 html latexpdf
+# cd docs
+# mkdir -p build
+# make -j1 html latexpdf
cd $srcdir/aws-$pkgver
PRJ_BUILD=Release DEBUG=false make -j1 prefix=/usr SOCKET=openssl setup
@@ -60,25 +66,29 @@ package()
cd $srcdir/aws-$pkgver
make -j1 DESTDIR="$pkgdir" install
+ rm $pkgdir/usr/bin/templates2ada
+ rm $pkgdir/usr/bin/templatespp
# Install the license.
+ #
install -D -m644 \
- "COPYING3" \
- "$pkgdir/usr/share/licenses/$pkgname/COPYING3"
+ COPYING3 \
+ $pkgdir/usr/share/licenses/$pkgname/COPYING3
# Install the custom license.
+ #
install -D -m644 \
- "COPYING.RUNTIME" \
- "$pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME"
-
-
- # Install the templates-parser license.
- install -D -m644 \
- "COPYING3" \
- "$pkgdir/usr/share/licenses/templates-parser/COPYING3"
-
- # Install the templates-parser custom license.
- install -D -m644 \
- "COPYING.RUNTIME" \
- "$pkgdir/usr/share/licenses/templates-parser/COPYING.RUNTIME"
-} \ No newline at end of file
+ COPYING.RUNTIME \
+ $pkgdir/usr/share/licenses/$pkgname/COPYING.RUNTIME
+
+
+# # Install the templates-parser license.
+# install -D -m644 \
+# "COPYING3" \
+# "$pkgdir/usr/share/licenses/templates-parser/COPYING3"
+#
+# # Install the templates-parser custom license.
+# install -D -m644 \
+# "COPYING.RUNTIME" \
+# "$pkgdir/usr/share/licenses/templates-parser/COPYING.RUNTIME"
+}