summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-03-27 10:18:16 +0100
committerAlexander F. Rødseth2019-03-27 10:18:16 +0100
commite6074faa0f638a80dea51f8d9f17d6c2b271de36 (patch)
tree85cf27a90cfe95961a48eb1b4fb439a498855a03 /PKGBUILD
downloadaur-e6074faa0f638a80dea51f8d9f17d6c2b271de36.tar.gz
Move from [community] to AUR in connection with the spring cleaning
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5f9fee207a20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer:
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=addinclude
+pkgver=1.0.1
+pkgrel=1
+pkgdesc='Utility to add include statements to header- and sourcefiles, for C and C++'
+arch=(x86_64)
+url='https://addinclude.roboticoverlords.org/'
+license=(GPL2)
+makedepends=(gcc-go)
+source=("https://addinclude.roboticoverlords.org/$pkgname-$pkgver.tar.xz"{,.asc})
+validpgpkeys=('962855F072C7A01846405864FCF3C8CB5CF9C8D4')
+sha256sums=('af3f5a7d3472b6a871150d82b9905e6a6571ad8d80820e382e20179c7aac2e67'
+ 'SKIP')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ go build -gccgoflags "-Wl,-z,relro,-z,now" -o $pkgname
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 $pkgname.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+}
+
+# vim: ts=2 sw=2 et: