summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCallum Parsey2023-02-19 15:15:44 +1030
committerCallum Parsey2023-02-19 15:15:44 +1030
commitb268f8c5a9572c56345e57a5c476d22b97c3f6e5 (patch)
tree373121d34ed048f1e78630755e788681e263ea16 /PKGBUILD
parentf7fbb30125a73eb8504813627dceac2d4600a901 (diff)
downloadaur-b268f8c5a9572c56345e57a5c476d22b97c3f6e5.tar.gz
Initial update to version 3.131
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 25 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e502d71217a0..567046c4abd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,41 @@
-# Maintainer: Laszlo Papp <lpapp@kde.org>
+# Maintainer: Callum Parsey <callum@neoninteger.au>
+# Contributor: Laszlo Papp <lpapp@kde.org>
+
+# TODO: The package is called `adduser-deb` for historical reasons. Merging it
+# into `adduser-debian` would simplify the logic involved in pulling and
+# extracting the upstream archives, but would require adding `replaces` and
+# `conflicts` directives. Neither is ideal.
pkgname=adduser-deb
-_pkgname=adduser
-pkgver=3.113+nmu3
+_pkgname=adduser-debian
+pkgver=3.131
pkgrel=1
-pkgdesc="Add and remove users and groups from Debian"
+pkgdesc="Debian's 'adduser' and 'deluser' commands for creating and removing users"
arch=('any')
-url="http://alioth.debian.org/projects/adduser/"
-license=('GPLv2')
+url="https://salsa.debian.org/debian/adduser"
+license=('GPL2')
+# TODO: Aren't `shadow` and `perl` also dependencies?
depends=('gawk')
-# source=("https://launchpad.net/debian/+archive/primary/+files/${_pkgname}_${pkgver}%2Bnmu3.tar.gz")
-source=("https://launchpad.net/debian/+archive/primary/+files/${_pkgname}_${pkgver}.tar.gz")
-md5sums=('ccb5864bde56683182c89c44474e7182')
+# TODO: Manage configuration files
+# TODO: ...changelog? Do other Arch packages actually use this?
+source=("https://salsa.debian.org/debian/adduser/-/archive/debian/${pkgver}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('3ce6de32bce048d12429d9431b36d8437c1934266475b6a9f5235b3dff54f918')
+# TODO: Run tests, but only in isolation from main system
+# TODO: Should include `copyright` file from repository for attribution info
+# TODO: Should include manpages/`README` from repository
+# TODO: What about `adduser.local`? What even is that?
+# TODO: Locale/translation files should also be included
package() {
install -D -m755 ${_pkgname}-${pkgver}/adduser "${pkgdir}/usr/bin/adduser"
install -D -m755 ${_pkgname}-${pkgver}/deluser "${pkgdir}/usr/bin/deluser"
ln -s adduser "${pkgdir}/usr/bin/addgroup"
ln -s deluser "${pkgdir}/usr/bin/delgroup"
+ # TODO: Do the policies defined in these files match Arch policy? Do I need
+ # to develop any patches for them?
install -D -m755 ${_pkgname}-${pkgver}/adduser.conf "${pkgdir}/etc/adduser.conf"
install -D -m755 ${_pkgname}-${pkgver}/deluser.conf "${pkgdir}/etc/deluser.conf"
install -D -m755 ${_pkgname}-${pkgver}/AdduserCommon.pm "${pkgdir}/usr/share/perl5/vendor_perl/Debian/AdduserCommon.pm"
+ # TODO: Patching should be done in `prepare()` step
sed -i "s/'-w',$gecos_work/'-p',$gecos_work/" ${pkgdir}/usr/bin/adduser
sed -i "s/'-r', $gecos_room/'-o', $gecos_room/" ${pkgdir}/usr/bin/adduser
}
-
-# vim:set ts=2 sw=2 et:
-