summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorleipero2017-09-28 20:57:45 +0200
committerleipero2017-09-28 20:57:45 +0200
commit81c86f605d63c7372315ecfc6ef0216c9e442d72 (patch)
treeaf9c4c6832352718541013e4d551e6af9a4ccfe0 /PKGBUILD
downloadaur-81c86f605d63c7372315ecfc6ef0216c9e442d72.tar.gz
first commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..253f2ff2d992
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: lpr1 (lei.pero@gmail.com)
+
+pkgname=adg-gtk-theme
+pkgver=3.22.3
+pkgrel=1
+pkgdesc="Slight gray modification of Adwaita theme from the GNOME Project."
+url="https://github.com/leipero/adg-gtk-theme"
+arch=(any)
+license=(GPL)
+depends=(sassc)
+makedepends=(sassc)
+options=(!emptydirs)
+source=("adg-gtk-theme-$pkgver.tar.gz"::"https://github.com/leipero/adg-gtk-theme/archive/$pkgver.tar.gz")
+sha256sums=('3956c7cf438d19245f63f4a03b6a393e070ef95dc826b8e029d2ac1793c5d304')
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ ./configure
+ make
+ make install
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -dm755 "$pkgdir/usr/share/themes"
+
+ cp -r "$srcdir"/$pkgname-$pkgver/themes/ "$pkgdir/usr/share"
+ make DESTDIR="$pkgdir/"
+ make uninstall
+ make clean
+}