summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStephen Gregoratto2018-01-08 00:27:27 +1100
committerStephen Gregoratto2018-01-08 00:27:27 +1100
commit0426fd1d70adee2656d7e667ec79dd9309f2dda8 (patch)
treef780e9833964d491c2c85b4ee3bdc5928864bea5 /PKGBUILD
parent69b8924f4d346385e80f3a9fcbfab8e2c7fe8033 (diff)
downloadaur-0426fd1d70adee2656d7e667ec79dd9309f2dda8.tar.gz
Add proper detection of pkgver(). Also, death to regex
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 4 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 329ce5ef9f54..1c62fdf191a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgdesc="Commandline program that plays MIDI via software OPL3 emulation"
pkgrel=1
pkgver=1.2.6
arch=('i686' 'x86_64')
-url="http://bisqwit.iki.fi/source/adlmidi.html"
+url="https://bisqwit.iki.fi/source/adlmidi.html"
license=('GPL3' 'GPL2+')
makedepends=('git')
optdepends=('ffmpeg: recording output to video file')
@@ -13,10 +13,9 @@ provides=(adlmidi)
source=("git://bisqwit.iki.fi/adlmidi.git")
sha256sums=('SKIP')
-#pkgver() {
-# cd "${pkgname/-git}"
-# printf "%s" "$(git describe --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
-#}
+pkgver() {
+ curl -s $url | grep -Po -m1 'adlmidi-\K[^/"]+' | head -1 | sed 's/.tar.bz2//g'
+}
build() {
cd "${pkgname/-git}"