summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJonathan Liu2015-06-19 11:57:54 +1000
committerJonathan Liu2015-06-19 11:57:54 +1000
commita3c1bc1e8fb286c9d81942b98a1023270ea9b2da (patch)
tree13eda7d3308568cc500e4033d444f18ad8f602ea /PKGBUILD
downloadaur-a3c1bc1e8fb286c9d81942b98a1023270ea9b2da.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05d995bb8843
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jonathan Liu <net147@gmail.com>
+pkgname=admesh
+pkgver=0.98.2
+pkgrel=1
+pkgdesc="Program for processing STL triangulated solid meshes"
+arch=('i686' 'x86_64')
+url="https://github.com/admesh/admesh/"
+license=('GPL2')
+depends=('glibc')
+source=("https://github.com/admesh/admesh/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('a90692eb6dc5289e95949bbbca3e37e9')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: