summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorOtto Sabart2015-06-30 09:36:12 +0000
committerOtto Sabart2015-06-30 09:36:12 +0000
commitc03cb022bd1e03ae932726735508fb7a3dd95556 (patch)
treee1b7f45bf7a5a2494f2bb69b0dfaf32b58d13202 /PKGBUILD
downloadaur-c03cb022bd1e03ae932726735508fb7a3dd95556.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a14d79ee320
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Sabart Otto - Seberm <seberm[at]gmail[dot]com>
+
+pkgname=adminer-editor
+pkgver=4.2.1
+pkgrel=1
+pkgdesc="Database data editing tool written in PHP"
+arch=('any')
+license=('Apache License, Version 2.0')
+depends=('php')
+conflicts=('')
+optdepends=('mariadb' 'apache' 'postgresql' 'sqlite' 'sqlite2')
+url="http://www.adminer.org/en/editor/"
+install=adminer-editor.install
+source=("http://downloads.sourceforge.net/adminer/editor-${pkgver}.php")
+
+package() {
+ _instdir=$pkgdir/usr/share/webapps/$pkgname
+ mkdir -p ${_instdir} $pkgdir/etc/webapps/$pkgname $pkgdir/etc/httpd/conf/extra
+
+ install -D -m644 $srcdir/editor-${pkgver}.php $_instdir/index.php
+
+ # It's similar to phpMyAdmin
+ cat >$pkgdir/etc/webapps/$pkgname/apache.example.conf <<EOF
+ Alias /${pkgname} "/usr/share/webapps/${pkgname}"
+ <Directory "/usr/share/webapps/${pkgname}">
+ AllowOverride All
+ Options FollowSymlinks
+ Require all granted
+ php_admin_value open_basedir "/srv/:/tmp/:/usr/share/webapps/:/etc/webapps:/usr/share/pear/"
+ </Directory>
+EOF
+
+ cp $pkgdir/etc/webapps/$pkgname/apache.example.conf $pkgdir/etc/httpd/conf/extra/httpd-${pkgname}.conf
+# echo "Include conf/extra/httpd-${pkgname}.conf" >> $pkgdir/etc/httpd/conf/httpd.conf
+
+}
+
+md5sums=('4bad913d9a3d2d665692d2e32a190d2e')