summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorredchenjs2019-07-14 01:51:26 +0800
committerredchenjs2019-07-14 01:51:26 +0800
commitd886ecf1614ece0a5e01cce50059a70105411709 (patch)
tree71ebf520ee780334c5c4556d0758eae0a8b1412c /PKGBUILD
parentf9ff7dda01d184bc4a8141f897b40d05d75f997e (diff)
downloadaur-d886ecf1614ece0a5e01cce50059a70105411709.tar.gz
set current package as a meta package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 7 insertions, 29 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9add26f8cd95..a8402ecde1ee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,14 @@
# Maintainer: Jack Chen <redchenjs@live.com>
pkgname=adobe-source-han-classic-fonts
-pkgver=1.0.0
-pkgrel=2
-pkgdesc="Adobe Source Han Fonts with Classic Style Chinese Character"
+pkgver=2.001
+pkgrel=1
+pkgdesc="Adobe Source Han Fonts - Classic Style Chinese Character"
arch=('any')
url="https://github.com/adobe-fonts/"
license=('OFL')
-source=(
- 'git+https://github.com/redchenjs/source-han-serif-classic.git'
- 'git+https://github.com/redchenjs/source-han-sans-classic.git'
- 'git+https://github.com/redchenjs/source-han-mono-classic.git'
+depends=(
+ 'adobe-source-han-serif-classic-fonts'
+ 'adobe-source-han-sans-classic-fonts'
+ 'adobe-source-han-mono-classic-fonts'
)
-md5sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
-
-package() {
- mkdir -p "${pkgdir}"/usr/
- mkdir -p "${pkgdir}"/usr/share/
- mkdir -p "${pkgdir}"/usr/share/fonts/
-
- mkdir -p "${pkgdir}"/usr/share/fonts/adobe-source-han-serif/
- mkdir -p "${pkgdir}"/usr/share/fonts/adobe-source-han-sans/
- mkdir -p "${pkgdir}"/usr/share/fonts/adobe-source-han-mono/
-
- cp -a "${srcdir}"/source-han-serif-classic/*.otf \
- "${pkgdir}"/usr/share/fonts/adobe-source-han-serif/
- cp -a "${srcdir}"/source-han-sans-classic/*.otf \
- "${pkgdir}"/usr/share/fonts/adobe-source-han-sans/
- cp -a "${srcdir}"/source-han-mono-classic/*.otf \
- "${pkgdir}"/usr/share/fonts/adobe-source-han-mono/
-}