summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRafael Fontenelle2024-01-29 00:32:13 -0300
committerRafael Fontenelle2024-01-29 00:32:13 -0300
commit0ae3da612c8c55cac74b32869308061550baaa83 (patch)
tree206db05e9f9634decd46e130ab2ac20369b8a15b /PKGBUILD
parent3260c1e92553df47be169bcfdc5eed4302320fe7 (diff)
downloadaur-0ae3da612c8c55cac74b32869308061550baaa83.tar.gz
Fix build for Python 3.11
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 12 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0e169b37badb..51b72241e54f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,16 +5,24 @@
pkgname=adonthell
pkgver=0.3.8
-pkgrel=1
+pkgrel=2
pkgdesc="A 2D graphical, single player role playing game engine"
arch=('x86_64')
url="http://adonthell.nongnu.org/"
-license=('GPL2')
+license=('GPL-2.0-or-later')
depends=('sdl2_mixer' 'sdl2_ttf' 'python')
makedepends=('swig')
options=('emptydirs')
-source=("http://savannah.nongnu.org/download/adonthell/$pkgname-src-$pkgver.tar.gz")
-sha256sums=('c006f95bc58f095eff1a6b4bfc3ec96a455c76cdc8b64c4b2430ad7775c2ccec')
+source=("http://savannah.nongnu.org/download/adonthell/$pkgname-src-$pkgver.tar.gz"
+ "remove-header-includes.patch")
+sha256sums=('c006f95bc58f095eff1a6b4bfc3ec96a455c76cdc8b64c4b2430ad7775c2ccec'
+ '59254960e4d165dfb318e1fd7e3c075f2aaed144af025fd832de716c9d131e43')
+
+prepare() {
+ cd $pkgname-$pkgver
+ # Remove includes of removed and duplicate called headers
+ patch -p1 -i "${srcdir}/remove-header-includes.patch"
+}
build() {
cd $pkgname-$pkgver