summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commitee557cc828ce2907624140afdfc4dae703bdb49c (patch)
treeb47c7323458e9c8e03f854f692b48997dd8d077b /PKGBUILD
downloadaur-ee557cc828ce2907624140afdfc4dae703bdb49c.tar.gz
Initial PKGBUILD status as of 28.11.2014
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6b10eeeef6dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Contributor: Christoph Zeiler <rabyte*gmail>
+
+pkgname=adonthell
+pkgver=0.3.5
+pkgrel=6
+pkgdesc="A 2D graphical, single player role playing game engine"
+arch=('i686' 'x86_64')
+url="http://adonthell.linuxgames.com/"
+license=('GPL')
+depends=('sdl_mixer>=1.2' 'sdl_ttf>=2' 'python>=2')
+source=(http://savannah.nongnu.org/download/$pkgname/$pkgname-src-$pkgver.tar.gz \
+ configure.diff)
+md5sums=('64a344b1ed8a7808d7adafa337120a00'
+ '196c9fd4240b3c2633dce3c864aa70fe')
+
+build() {
+ cd $pkgname-$pkgver
+
+ patch -Np0 -i ../configure.diff || return 1
+
+ # NEW NEW NEW ;-) Set default screen-mode to fullscreen!!
+ sed 's|screen_mode = 0|screen_mode = 1|g' -i src/prefs.cc
+
+ ./configure --prefix=/usr
+ make || return 1
+ make DESTDIR=$pkgdir install
+}