summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Nielsen2016-04-30 15:20:50 +1000
committerAdam Nielsen2016-04-30 15:20:50 +1000
commitb5c2fa5f8ed649bd974cf1a0328bd531138e4191 (patch)
treec7714fb96026c7cc6c8d71343436e4ae1cba9f3e /PKGBUILD
downloadaur-b5c2fa5f8ed649bd974cf1a0328bd531138e4191.tar.gz
Initial version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb157d30f4fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Adam Nielsen <malvineous@shikadi.net>
+
+pkgname=adplug-git
+pkgver=20160430
+pkgrel=1
+pkgdesc="AdLib sound player library"
+arch=('i686' 'x86_64')
+url="http://adplug.github.io"
+license=('LGPL')
+depends=('libbinio')
+provides=('adplug')
+conflicts=('adplug')
+source=("git://github.com/adplug/adplug.git")
+md5sums=('SKIP')
+
+prepare() {
+ cd "$srcdir/adplug"
+
+ autoreconf -fis
+}
+
+build() {
+ cd "$srcdir/adplug"
+ ./configure --prefix=/usr --enable-maintainer-mode
+ make
+}
+
+check() {
+ cd "$srcdir/adplug"
+ make check
+}
+
+package() {
+ cd "$srcdir/adplug"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir/usr/share/info/dir"
+}