summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Nielsen2016-04-01 17:59:33 +1000
committerAdam Nielsen2016-04-01 17:59:33 +1000
commit026992f71f3cef7237389aa8804abe241ef1df0c (patch)
treeb69207c6442ce71b3dac38809a76d54a48afaf87 /PKGBUILD
downloadaur-026992f71f3cef7237389aa8804abe241ef1df0c.tar.gz
Add MAME patch to adplug AUR package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1cf02c4d5114
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Adam Nielsen <malvineous@shikadi.net>
+# Based on adplug package by Mikael Eriksson <mikael_eriksson@miffe.org>
+
+pkgname=adplug-mame
+pkgver=2.2.1
+pkgrel=2
+pkgdesc="AdLib sound player library"
+arch=('i686' 'x86_64')
+url="http://adplug.github.io"
+license=('LGPL')
+depends=('libbinio')
+provides=('adplug')
+conflicts=('adplug')
+source=(https://github.com/adplug/adplug/releases/download/adplug-$pkgver/adplug-$pkgver.tar.bz2
+ http://www.shikadi.net/adplug/files/adplug-2.2_mame.patch.zip)
+md5sums=('8f815fd5d254de0fe5df818df9d1d8af'
+ '1702935614e1cb401a9d556308e9f841')
+
+prepare() {
+ cd "$srcdir/adplug-$pkgver"
+
+ patch -p1 -i $srcdir/adplug-2.2_mame.patch
+
+ autoreconf -fis
+}
+
+build() {
+ cd "$srcdir/adplug-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/adplug-$pkgver"
+ make DESTDIR="$pkgdir" install
+ rm "$pkgdir/usr/share/info/dir"
+}
+
+# vim:set ts=2 sw=2 et: