summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPavan Rikhi2022-12-13 20:21:29 -0500
committerPavan Rikhi2022-12-13 20:21:29 -0500
commit8292615aebe966c1feff4f20073e5f0f9c7a525a (patch)
treefe3dd43967d19e53786acc205c1cd3cc3bf918b2 /PKGBUILD
parent23a0e0a239a946d833057ebd1a72d06a0e3bbb37 (diff)
downloadaur-adwaita-custom-cursor-colors.tar.gz
Bump to v43, Hack Around Broken Inkscape With Dockerfile
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 32 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6bb64bf49ef7..8e30400b854d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,46 @@
# Contributor: Lukas Fleischer <lfleischer@archlinux.org>
# Contributor: Jan de Groot <jgc@archlinux.org>
+# NOTE: This is broken with the latest inkscape CLI & you will have to comment
+# out the renderpngs.py script for now, using docker to run the script in a
+# debian environment.
+#
+# Start by extracting & preparing the source files, this command will fail:
+# $ makepkg
+#
+# Run these commands to generate icon PNGs from the base SVG file:
+# $ docker build -t adwaita:latest .
+# $ docker run --mount type=bind,source=./src/adwaita-icon-theme-43,target=/app adwaita
+#
+# Then comment out the ./renderpngs.py line in build() & finish building the
+# package with:
+# $ makepkg --noextract --noprepare --install
+
# To Change the Colors of the Generated Cursor Files, Edit the FILL_COLOR &
# OUTLINE_COLOR Variables in the `build()` Function.
pkgname=adwaita-custom-cursor-colors
-pkgver=3.36.0
+pkgver=43
pkgrel=1
pkgdesc="GNOME's Adwaita Theme with Customizable Cursor Colors"
url="https://git.gnome.org/browse/adwaita-icon-theme"
arch=(any)
license=(LGPL3 CCPL:cc-by-sa)
depends=(hicolor-icon-theme gtk-update-icon-cache librsvg)
-makedepends=(intltool git gtk3 gnome-common python2 python2-pillow inkscape xorg-xcursorgen)
-provides=(adwaita-icon-theme)
-conflicts=(adwaita-icon-theme)
-source=("https://github.com/GNOME/adwaita-icon-theme/archive/$pkgver.tar.gz")
-sha256sums=('813a094e60c375e7ed527ef5f3c02adbeab086b5b7b64a7bda6b2aa9fd4dadf4')
+#makedepends=(intltool git gtk3 gnome-common python python-pillow inkscape xorg-xcursorgen)
+makedepends=(intltool git gtk3 gnome-common docker)
+provides=(adwaita-icon-theme adwaita-cursors)
+conflicts=(adwaita-icon-theme adwaita-cursors)
+source=(
+ "https://github.com/GNOME/adwaita-icon-theme/archive/$pkgver.tar.gz"
+ "Dockerfile"
+ "makepngs.sh"
+)
+sha256sums=(
+ '15c635c227f85d78121841e40815ed5277c7580c9c80e01f1613a807d931b4c1'
+ 'SKIP'
+ 'SKIP'
+)
_sourcefolder="adwaita-icon-theme-$pkgver"
@@ -25,7 +49,7 @@ prepare() {
cd "$_sourcefolder"
autoreconf -fvi
}
-
+
build() {
cd "$_sourcefolder"
@@ -57,6 +81,7 @@ build() {
sed -i "s/${TEMP_VAR}/${OUTLINE_COLOR}/g" adwaita.svg
# Generate PNGs from the SVG
+ # NOTE: This is broken, see comment at top of PKGBUILD
CORE_COUNT="$(grep -c '^core id' /proc/cpuinfo)"
./renderpngs.py -r -s -t -o -m 32 -a -c -n "${CORE_COUNT}" adwaita.svg