summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoréclairevoyant2022-12-02 23:21:43 -0500
committeréclairevoyant2022-12-02 23:21:43 -0500
commita89bb45961d4add19f3c1e06347c4a2677d45cdd (patch)
tree0d0eeeab5e0698a13e7bb49c78b921fadbe52f0b /PKGBUILD
parent6591d42b372186d226643513f0fa1944921c6d1f (diff)
downloadaur-a89bb45961d4add19f3c1e06347c4a2677d45cdd.tar.gz
adwaita-icon-theme-git: split package into cursors and icons
Signed-off-by: éclairevoyant <848000+eclairevoyant@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 19 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bd0db7799a10..6e7da9d92bd9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,9 @@
# Contributor: Philip Goto <philip dot goto at gmail.com>
_pkgname=adwaita-icon-theme
-pkgname="$_pkgname-git"
-pkgver=43.r60.g4f8e8dc69
+pkgbase="$_pkgname-git"
+pkgname=("$pkgbase" 'adwaita-cursors-git')
+pkgver=43.r68.g855de98ff
pkgrel=1
pkgdesc='GNOME standard icons'
arch=('any')
@@ -11,8 +12,6 @@ url="https://gitlab.gnome.org/GNOME/$_pkgname"
license=('LGPL3' 'CCPL:by-sa')
depends=('hicolor-icon-theme' 'gtk-update-icon-cache' 'librsvg')
makedepends=('git' 'gtk3')
-provides=("$_pkgname")
-conflicts=("$_pkgname")
source=("git+$url.git")
b2sums=('SKIP')
@@ -36,6 +35,21 @@ check() {
make -C $_pkgname check
}
-package() {
+package_adwaita-icon-theme-git() {
+ depends+=('adwaita-cursors')
+ provides=("$_pkgname")
+ conflicts=("$_pkgname")
+
make -C $_pkgname DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir/usr/share/icons/Adwaita/cursors/"
+}
+
+package_adwaita-cursors-git() {
+ pkgdesc='GNOME standard cursors'
+ unset depends
+ provides=('adwaita-cursors')
+ conflicts=('adwaita-cursors')
+
+ install -dm755 "$pkgdir/usr/share/icons/Adwaita/"
+ cp -r --no-preserve=ownership $_pkgname/Adwaita/cursors "$pkgdir/usr/share/icons/Adwaita/"
}