summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBrian Bidulock2019-09-30 22:22:12 -0600
committerBrian Bidulock2019-09-30 22:22:12 -0600
commitd6cc4f0c547dba11ab4ec04e47f1535d640d469b (patch)
tree749adb4c775a4e0cb40e647901b412d353b4349e /PKGBUILD
parent22a992a2f8034b1c55bce3626bc262fad07283c0 (diff)
downloadaur-d6cc4f0c547dba11ab4ec04e47f1535d640d469b.tar.gz
better provides version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c92d54cdb5b0..523746f3cafa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,15 @@
# Maintainer: Brian Bidulock <bidulock@openss7.org>
pkgname=adwm-git
+_pkgname=adwm
pkgver=0.7.8.r0.g800df77
-pkgrel=1
+pkgrel=2
pkgdesc="Advanced dynamic window manager for X"
arch=('i686' 'x86_64')
-url="http://github.com/bbidulock/adwm"
+url="http://github.com/bbidulock/$_pkgname"
license=('GPL')
-provides=('adwm')
-conflicts=('adwm')
+provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
+conflicts=("${_pkgname}")
depends=('libxft' 'libxrandr' 'libxinerama' 'libxpm' 'startup-notification' 'libxcomposite' 'libxdamage' 'libjpeg-turbo' 'libsvg-cairo')
optdepends=('xdg-launch-git: for application launching key bindings'
'xde-ctools-git: for xde-run, xde-winmenu, xde-winlist and xde-wkspmenu default bindings'
@@ -16,7 +17,7 @@ optdepends=('xdg-launch-git: for application launching key bindings'
'xde-session-git: for xde-logout and xde-xlock default bindings')
options=('!libtool' '!strip' 'debug')
makedepends=('git' 'perl-timedate')
-source=("$pkgname::git+https://github.com/bbidulock/adwm")
+source=("$pkgname::git+https://github.com/bbidulock/$_pkgname")
md5sums=('SKIP')
pkgver() {
@@ -36,8 +37,7 @@ build() {
}
package() {
- cd $pkgname
- make DESTDIR="$pkgdir" install
+ make -C $pkgname DESTDIR="$pkgdir" install
}
# vim:set ts=2 sw=2 et: