summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2016-09-16 14:03:20 -0600
committerAinola2016-09-16 14:03:20 -0600
commit2503e9405be75cfa11a1d6c0ad9655a2f7b6c04f (patch)
tree6000b3b5eba1e4c09840015d89540a1d3f6b593b /PKGBUILD
parentf294d47d616368ffd9b64df67b0e6f79550c13bd (diff)
downloadaur-2503e9405be75cfa11a1d6c0ad9655a2f7b6c04f.tar.gz
upgpkg: 3.4.0.12, add compilation patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2a9d6f16f70d..6879b3f6d8d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: quantax
pkgname=ags
-pkgver=3.3.5.11
+pkgver=3.4.0.12
pkgrel=1
pkgdesc="A development tool that is primarily used to create graphical adventure games"
arch=('i686' 'x86_64')
@@ -13,10 +13,16 @@ depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis')
makedepends=('wxgtk')
optdepends=('wine: for installing and configuring the game')
install=ags.install
-source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
-sha256sums=('029e0a4f2c12617a9672eee7cfc7e9c9aba0421bfb18c8a8210bf7fba5f63825')
+source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz"
+ "fix-cpp-11-mode.patch")
+sha256sums=('64422a3ad7ed1d78d207158f6d8a67499e6d0b50a9dd6438d086373ac66d1a76'
+ '67ba92334c08626cec954edca5e164fdb619d690e518685402632be9ea4348ce')
prepare() {
+ # Fixes https://github.com/adventuregamestudio/ags/issues/356 until an
+ # official release
+ patch -p1 -d "$srcdir/ags-v.${pkgver}" < fix-cpp-11-mode.patch
+
cd "$srcdir/ags-v.${pkgver}"
sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux
}