summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2018-08-25 12:19:29 -0600
committerAinola2018-08-25 12:19:47 -0600
commit84ec1ef8638ec9e6e56c5e5c8fb126099f2cad5f (patch)
tree82d474df815423b3a7df0648816aff739f536b8f /PKGBUILD
parent35fef631b02d53580171f76a4e963d7d231143e2 (diff)
downloadaur-84ec1ef8638ec9e6e56c5e5c8fb126099f2cad5f.tar.gz
suppress deprecated declarations and not fatal
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 90dc3f84bd80..b743465c8f0c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,7 +17,10 @@ source=("https://github.com/adventuregamestudio/ags/archive/v.${pkgver}.tar.gz")
sha256sums=('7dd75df2131333f1b6885c89db275e0dee3f7b55d3d9c4e8afae612c94aca4e2')
prepare() {
- sed -i 's/-Wfatal-errors\ //' "ags-v.$pkgver/Engine/Makefile-defs.linux"
+ # Copious use of auto_ptr spams the compilation output. Until they're
+ # replaced, just suppress the message.
+ sed -i 's/-Wfatal-errors/-Wfatal-errors\ -Wno-deprecated-declarations/' \
+ "ags-v.$pkgver/Engine/Makefile-defs.linux"
}
build() {