summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAinola2018-09-02 11:18:49 -0600
committerAinola2018-09-02 11:18:49 -0600
commit9c6d3a8581bf7842345cdd0df79ab39d55250603 (patch)
tree44ae0c6b6518ed780cdb1c791fa7fad0ce4e1df6 /PKGBUILD
parente8c859636f1617bec943fa2a21684e1bf0957d75 (diff)
downloadaur-9c6d3a8581bf7842345cdd0df79ab39d55250603.tar.gz
pkg cleanup
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 8 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c0503dac259..229e43547890 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,9 +5,9 @@
pkgname=ags
pkgver=3.4.1.14
-pkgrel=1
+pkgrel=2
pkgdesc='A development tool that is primarily used to create graphical adventure games'
-arch=('i686' 'x86_64')
+arch=('x86_64')
url='https://github.com/adventuregamestudio/ags'
license=('Artistic2.0')
depends=('allegro4' 'dumb-a4' 'libogg' 'libtheora' 'libvorbis')
@@ -19,26 +19,25 @@ sha256sums=('4ca76b919689c68a9fda4bd56bfb63268ab5326a539ce4d681ac4ed6a908b51c'
'6b7092e5794ae532f79c5c6ad5f5761c217b3ec874da43537152fb8e60b20019')
prepare() {
+ mv "ags-v.$pkgver" "$pkgname-$pkgver"
+
# Copious use of auto_ptr spams the compilation output. Until they're
# replaced, just suppress the message.
sed -i 's/-Wfatal-errors/-Wfatal-errors\ -Wno-deprecated-declarations/' \
- "ags-v.$pkgver/Engine/Makefile-defs.linux"
+ "$pkgname-$pkgver/Engine/Makefile-defs.linux"
# avoid conflicts with glibc functions with the same names
- cd "$srcdir/ags-v.${pkgver}"
- patch -p1 < ../44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
+ patch -d "$pkgname-$pkgver" -p1 < ../44d954493bb5f3e95a11a4eddbb62bd6110b1b63.patch
}
build() {
- cd "$srcdir/ags-v.${pkgver}"
+ cd "ags-v.${pkgver}"
make -C Engine
}
package() {
- install -Dm755 "$srcdir/ags-v.${pkgver}/Engine/ags" \
+ install -Dm755 "ags-v.${pkgver}/Engine/ags" \
"$pkgdir/usr/bin/ags"
- install -Dm644 "$srcdir/ags-v.${pkgver}/License.txt" \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
# vim: ts=2 sw=2 et