diff options
author | Dan Beste | 2017-02-18 21:59:43 -0600 |
---|---|---|
committer | Dan Beste | 2017-02-18 21:59:43 -0600 |
commit | 9bde3121055c2d1e07cb049988b709e2b960b25f (patch) | |
tree | e9b6d351d99ebdb04e0786b862621ffc6da5e99e /PKGBUILD | |
parent | d70d53821a3c3246ca9f199a1ab824f0a9715c8f (diff) | |
download | aur-9bde3121055c2d1e07cb049988b709e2b960b25f.tar.gz |
Clean PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 77 |
1 files changed, 52 insertions, 25 deletions
@@ -1,42 +1,69 @@ -# Maintainer: Frederic Bezies <fredbezies at gmail dot com> +# Maintainer: Dan Beste <dan.ray.beste@gmail.com> # Contributor: Ainola # Contributor: Ner0 # Contributor: quantax -pkgname=ags-git -pkgver=v.3.3.5.4.r0.g1ea2d33 +# Previously: +# Maintainer: Frederic Bezies <fredbezies at gmail dot com> + +pkgname='ags-git' +_pkgname='ags' +pkgver=3.4.1.1.r13.g6053e954 pkgrel=1 pkgdesc="Adventure Game Studio, a development tool that is primarily used to create graphical adventure games" -arch=('i686' 'x86_64') -url="https://github.com/adventuregamestudio/ags" -license=('Artistic2.0') -depends=('allegro' 'dumb' 'libogg' 'libtheora' 'libvorbis') -makedepends=('git' 'wxgtk') -optdepends=('wine: for installing and configuring the game') -conflicts=('ags') -install=ags.install -source=('git://github.com/adventuregamestudio/ags.git') -md5sums=('SKIP') +arch=( + 'i686' + 'x86_64' +) +url='http://www.adventuregamestudio.co.uk/' +license=( + 'custom: Artistic 2.0' +) +depends=( + 'allegro' + 'dumb' + 'libogg' + 'libtheora' + 'libvorbis' +) +makedepends=( + 'git' +) +optdepends=( + 'wine: For non-native games' +) +conflicts=( + 'ags' +) +source=( + 'git://github.com/adventuregamestudio/ags.git' +) +sha256sums=( + 'SKIP' +) pkgver() { - cd "$srcdir/ags" - git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' -} + cd "${srcdir}/${_pkgname}" || exit 1 -#prepare() { -# cd "$srcdir/ags" -# sed -i 's/-Wfatal-errors\ //' Engine/Makefile-defs.linux -# git submodule update --init -#} + git describe --long --tags \ + | sed 's/\([^-]*-g\)/r\1/;s/-/./g' \ + | sed 's/v.//' +} build() { - cd "$srcdir/ags" - make -C Engine + cd "${srcdir}/${_pkgname}" || exit 1 + + make --directory=Engine } package() { - install -Dm755 "$srcdir/ags/Engine/ags" "$pkgdir/usr/bin/ags" - install -Dm644 "$srcdir/ags/License.txt" "$pkgdir/usr/share/licenses/$pkgname/LICENSE" + install -Dm755 \ + "${srcdir}/${_pkgname}/Engine/${_pkgname}" \ + "${pkgdir}/usr/bin/${_pkgname}" + + install -Dm644 \ + "${srcdir}/${_pkgname}/License.txt" \ + "${pkgdir}/usr/share/licenses/$pkgname/LICENSE" } |