summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJan Keith Darunday2020-09-12 12:41:55 +0800
committerJan Keith Darunday2020-09-12 12:42:51 +0800
commit2549b898a48c5b807499d68b98219bc1ca2f90bf (patch)
tree78c1f3de7c83de7150a38c6c0d2bc21a4aa49655 /PKGBUILD
parentbf7d5a43016814a6337f5665ae0129f51b630714 (diff)
downloadaur-2549b898a48c5b807499d68b98219bc1ca2f90bf.tar.gz
Follow meson PKGBUILD guidelines and add gitignore file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 12 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 43c94efed655..9e017387a14f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,16 @@
pkgname=ahoviewer-git
_pkgname=ahoviewer
pkgver=1.6.5.127.g518c20c
-pkgrel=1
-pkgdesc="A GTK2 image viewer, manga reader, and booru browser."
+pkgrel=2
+pkgdesc='A GTK2 image viewer, manga reader, and booru browser.'
arch=('i686' 'x86_64')
-url="http://github.com/ahodesuka/ahoviewer"
+url='http://github.com/ahodesuka/ahoviewer'
license=('MIT')
depends=('gtkmm3>=3.22.0' 'libconfig>=1.4')
optdepends=('gstreamer' 'gst-plugins-base' 'gst-plugins-bad' 'gst-plugins-good' 'gst-libav' 'libpeas>=1.22.0' 'libsecret' 'libunrar' 'libzip' )
-makedepends=('git' 'meson' 'ninja')
+makedepends=('meson')
provides=('ahoviewer')
-source=("git://github.com/ahodesuka/ahoviewer")
+source=('git://github.com/ahodesuka/ahoviewer')
md5sums=('SKIP')
pkgver() {
@@ -20,19 +20,18 @@ pkgver() {
git describe | sed 's/-/./g'
}
-prepare() {
- cd $srcdir/$_pkgname
- meson build --prefix=/usr -Dbuildtype=release
+build() {
+ arch-meson --auto-features=auto $_pkgname build
+ meson compile -C build
}
-build() {
- cd $srcdir/$_pkgname/build
- ninja
+
+check() {
+ meson test -C build
}
package() {
- cd $srcdir/$_pkgname/build
- DESTDIR="$pkgdir" ninja install
+ DESTDIR="$pkgdir" meson install -C build
install -Dm644 $srcdir/ahoviewer/LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}