summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBad Cast2022-12-13 13:04:16 +0600
committerBad Cast2022-12-13 21:04:22 +0600
commit3b6e67bd50cf41eb8e9f1ce334a4307ad368dc5e (patch)
tree5a8247e2d9e90c6db3e8210bf497670cdc97fe77 /PKGBUILD
parent4dff4029ad118ae847068207a73b11d294b2d027 (diff)
downloadaur-3b6e67bd50cf41eb8e9f1ce334a4307ad368dc5e.tar.gz
Updated version to 5.10.2417. Updated DesktopFile, Fixed owner bug's. Passing system arguments fixed.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8f97c3340be..d60d8c3a932e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,31 +3,24 @@
pkgname=aimp
pkgver=5.10
-pkgrel=2414
+pkgrel=2417
url="https://www.aimp.ru/"
pkgdesc="AIMP (on Wine) is powerful free audio player."
arch=('x86_64')
license=('custom')
depends=('wine')
source=("https://www.aimp.ru/files/linux/aimp_${pkgver}-${pkgrel}_amd64.deb")
-md5sums=('e56fc3e3db95d2baf5160956057cca46')
+md5sums=('9b562a6054ce4fec9dd6fdb2f284da46')
build(){
cd "${srcdir}"
echo "Append aimp (shell):/usr/bin/aimp"
- #save patch
- echo "#!/usr/bin/sh
-#Convert Linux paths to Windows paths.
-#Example:
-#GNU LINUX | WINDOWS OS
-# \$HOME = %USERPROFILE%\\ (etc).
-_paths=\$(winepath --windows \"\$@\")
-/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMP.exe' \${_paths}" > aimp
}
package(){
desktopfile="aimp.desktop"
+ runner="aimp"
dest="$pkgdir/opt/aimp"
cd "${srcdir}"
@@ -37,12 +30,16 @@ package(){
#set a prompt mode +x
chmod +x "$pkgdir/opt/aimp/${desktopfile}"
+ #remove owner
rm -f "$dest/${desktopfile}"
- rm -f "$dest/aimp.bash"
+ rm -f "$dest/${runner}.bash"
+ #replace owner
#fix owner bug's
+
#append Desktop.file
install -Dm644 ../${desktopfile} "$pkgdir/usr/share/applications/${desktopfile}"
-
- install -Dm755 aimp "$pkgdir/usr/bin/aimp"
+
+ #append /usr/bin/aimp file
+ install -Dm755 ../${runner} "$pkgdir/usr/bin/aimp"
}