summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbadcast2022-12-05 00:19:48 +0600
committerbadcast2022-12-05 00:33:09 +0600
commitbfcc6de9d6cb137a589410bf2da0eea694a7933d (patch)
tree725563a7675720993c72b2dea4dd43b0092aa071 /PKGBUILD
parent61080f4750648184cd58295875aa4a6418f07d88 (diff)
downloadaur-bfcc6de9d6cb137a589410bf2da0eea694a7933d.tar.gz
Windows Path converter added (winepath)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dccac60d3964..a8f97c3340be 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,12 @@ build(){
echo "Append aimp (shell):/usr/bin/aimp"
#save patch
echo "#!/usr/bin/sh
-/usr/bin/wine '/opt/aimp/AIMP/AIMP.exe' \"\$@\"" > aimp
+#Convert Linux paths to Windows paths.
+#Example:
+#GNU LINUX | WINDOWS OS
+# \$HOME = %USERPROFILE%\\ (etc).
+_paths=\$(winepath --windows \"\$@\")
+/usr/bin/wine start /unix '/opt/aimp/AIMP/AIMP.exe' \${_paths}" > aimp
}
package(){