summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorqwertzdenek2017-10-27 10:21:07 +0200
committerqwertzdenek2017-10-27 10:21:07 +0200
commit42209faddd55412eedbb03c84370aa95b749203b (patch)
tree0a503c97a16c2ee88ec225d8aaa0cd2cce1fa865 /PKGBUILD
parent5b92656afca9b93ce1fa80f9ce399ebe8f7ee172 (diff)
downloadaur-42209faddd55412eedbb03c84370aa95b749203b.tar.gz
switched to OpenSSL 1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7c408820d4f3..15e478a1f092 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Zdenek Janecek <ycdmdj@gmail.com>
pkgname=airdcpp-webclient-git
-pkgver=r2725.1a932a46
-pkgrel=2
+pkgver=r2993.b58859d0
+pkgrel=1
_gitname=airdcpp-webclient
pkgdesc="A peer-to-peer file sharing client with web user interface."
arch=('i686' 'x86_64' 'armv7h')
url="https://airdcpp-web.github.io"
license=('GPL')
-depends=('miniupnpc' 'boost' 'openssl' 'geoip' 'leveldb' 'websocketpp' 'libnatpmp' 'intel-tbb')
+depends=('miniupnpc' 'boost' 'openssl-1.0' 'geoip' 'leveldb' 'websocketpp' 'libnatpmp' 'intel-tbb')
makedepends=('cmake' 'git')
source=('git+https://github.com/airdcpp-web/airdcpp-webclient.git'
'airdcpp.service'
@@ -30,8 +30,10 @@ pkgver() {
build() {
cd ${srcdir}/${_gitname}
+ export PKG_CONFIG_PATH=/usr/lib/openssl-1.0/pkgconfig
+
cmake . -DCMAKE_INSTALL_PREFIX=/usr
- make -j4
+ make
}
package() {