summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTeteros2021-09-05 15:42:06 +0100
committerTeteros2021-09-05 15:42:06 +0100
commit7f49682d85851bb388765d6b6f46ae78f4779300 (patch)
tree7b7336448123b41da2acc8910cc08d6e64fae772 /PKGBUILD
parent33fbbd5d2d5e65762653dd0928e855b23cdbec31 (diff)
downloadaur-airwindows-git.tar.gz
Add missing directory and optimisations
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bc3aa4614334..289d6c220c80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Teteros <teteros at teknik dot io>
pkgname=airwindows-git
-pkgver=r130.0d16be1
+pkgver=r225.a4343495
pkgrel=1
pkgdesc="Airwindows plugins are modular, graphic-less, stripped-down, VST plugins for Mac and PC"
arch=(x86_64)
@@ -24,13 +24,13 @@ prepare() {
# Fix cmake build, see:
# https://github.com/airwindows/airwindows/pull/5
rm -f build/CMakeCache.txt
- mkdir -p include/vstsdk
+ mkdir -p include/vstsdk build
cp "${srcdir}/CMakeLists.txt" include/vstsdk/CMakeLists.txt
}
build() {
cd "${pkgname%-*}/plugins/LinuxVST/build"
- cmake -DVSTSDK_ROOT=/usr/include/vst36 ..
+ cmake -DVSTSDK_ROOT=/usr/include/vst36 -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS="-O3 -ffast-math" ..
make || return 1
}