summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorhaawda2019-10-09 22:00:52 +0200
committerhaawda2019-10-09 22:00:52 +0200
commit02636e3c58cc0cf2b33dd5a9b7ad1ea7b65da32a (patch)
treef5abfc8f4bcc33ea5fdfe80ee46efa1c36ef2162 /PKGBUILD
parent323f35ba660d1d3363d9ed84c1d062587814d881 (diff)
downloadaur-02636e3c58cc0cf2b33dd5a9b7ad1ea7b65da32a.tar.gz
rewrite for new meson buildsystem
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD34
1 files changed, 12 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5511f245338f..aa5f99161713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,20 +2,19 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=aisleriot-git
-pkgver=3.22.8.r6.g21bf497e
+pkgver=3.22.9.r26.g0183c06d
pkgrel=1
pkgdesc="A collection of patience games written in guile scheme"
url="https://wiki.gnome.org/Apps/Aisleriot"
arch=('x86_64')
license=('GPL')
-depends=('guile' 'gtk3' 'librsvg' 'libcanberra' 'dconf')
+depends=('guile' 'gtk3' 'qt5-svg')
provides=('aisleriot')
conflicts=('aisleriot')
-makedepends=('appdata-tools' 'gnome-common' 'git')
-optdepends=('libkdegames: KDE card sets'
- 'pysolfc: PySol card sets'
+makedepends=('appdata-tools' 'libkdegames' 'gnome-common' 'git')
+optdepends=('pysolfc: PySol card sets'
'pysolfc-cardsets: PySol card sets')
-options=('!emptydirs')
+options=('!strip' '!emptydirs')
source=("git+https://gitlab.gnome.org/GNOME/aisleriot.git")
sha256sums=('SKIP')
@@ -26,24 +25,15 @@ pkgver() {
build() {
cd ${pkgname%-git}
- NOCONFIGURE=1 ./autogen.sh
- ./configure \
- --prefix=/usr \
- --sysconfdir=/etc \
- --localstatedir=/var \
- --libexecdir=/usr/lib \
- --disable-static \
- --with-platform=gtk-only \
- --with-kde-card-theme-path=/usr/share/carddecks \
- --with-pysol-card-theme-path=/usr/share/PySolFC
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
-
- make
+ [[ -d builddir ]] || mkdir builddir
+ meson . builddir --prefix=/usr \
+ --libexecdir=/usr/lib \
+ -Dtheme_kde_path=/usr/share/carddecks \
+ --buildtype=plain
+ ninja -j1 -C builddir
}
package() {
cd ${pkgname%-git}
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C builddir install
}