summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorosmank32022-01-05 16:19:08 +0300
committerosmank32022-01-05 16:19:08 +0300
commit442d9bf97093e5a37c91d14bc35f72779ec36451 (patch)
tree750354742ba9abe7300ad95cb5abf72fd6789f5b /PKGBUILD
parent8ab0e498f13354bc4a6cee8569d569647fc03394 (diff)
downloadaur-442d9bf97093e5a37c91d14bc35f72779ec36451.tar.gz
Cleanup building files and change website
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 88523e562f33..5b9c2b25f3ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,30 +6,21 @@ pkgver=6.2.1
pkgrel=1
pkgdesc="PKCS#11 library and utility tools for Akis Smartcard"
arch=('x86_64')
-url="http://www.akiskart.com.tr"
+url="https://akiskart.bilgem.tubitak.gov.tr/"
license=('custom')
-makedepends=('unrar')
depends=('pcsclite' 'ccid' 'java-environment')
install=akia.install
-source=(akia
+source=(akia.patch
https://akiskart.bilgem.tubitak.gov.tr/dosyalar/akis_${pkgver}_amd64.rar)
-sha256sums=('cd71c80eda1674ca8b0cc8f86fdf7404b89edfc910c4460cf62ed8d706cfe609'
+sha256sums=('180d9fe95b6c94d6e4377701bd1bdf116e722d5baedbd57b509b0c12339dc503'
'2e1fb8f8b176e3e674ec72e3f0394abc1de95a5d044e610ddf8255709c13f20a')
prepare() {
- unrar x akis_${pkgver}_amd64.rar
ar x akis_${pkgver}_amd64.deb
+ tar -zxf data.tar.gz -C "${srcdir}"
+ patch --forward --strip=1 --input="akia.patch"
}
package() {
-
- tar -zxf data.tar.gz -C "${srcdir}"
-
- rm -rf "${srcdir}"/usr/bin
-
- install -dm755 "${pkgdir}"/usr
- install -dm755 "${pkgdir}"/usr/bin
-
- mv "${srcdir}"/usr/* "${pkgdir}"/usr
- install -Dm755 "${srcdir}"/akia "${pkgdir}"/usr/bin/akia
+ mv "${srcdir}"/usr "${pkgdir}"/usr
}