summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilip Goto2018-03-19 22:51:58 +0100
committerPhilip Goto2018-03-19 22:51:58 +0100
commit8e2f2ecd5974f0d3b7c65b02abc202b063d09d91 (patch)
tree719a79457d0831e145598cbb5f2f90dc8d8dcf2c /PKGBUILD
downloadaur-8e2f2ecd5974f0d3b7c65b02abc202b063d09d91.tar.gz
Initialize package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9fe2307b8ff3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Philip Goto <philip.goto@gmail.com>
+pkgname=akira-git
+pkgver=latest
+pkgrel=1
+pkgdesc="Native Linux App for UI and UX Design built in Vala and Gtk"
+arch=(x86_64)
+url="https://github.com/Alecaddd/Akira"
+license=(GPL3)
+makedepends=(meson)
+provides=(akira)
+source=("git+https://github.com/Alecaddd/Akira.git")
+sha256sums=(SKIP)
+
+prepare() {
+ mkdir build
+}
+
+build() {
+ cd build
+ meson --prefix=/usr --buildtype=release ../Akira
+ ninja
+}
+
+check() {
+ cd build
+ ninja test
+}
+
+package() {
+ cd build
+ DESTDIR="$pkgdir" ninja install
+}